kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Corey Nolet <cjno...@gmail.com>
Subject Fwd: Verioning
Date Mon, 09 Mar 2015 17:11:08 GMT
I'm new to Kafka and I'm trying to understand the version semantics. We
want to use Kafka w/ Spark but our version of Spark is tied to 0.8.0. We
were wondering what guarantees are made about backwards compatbility across
0.8.x.x. At first glance, given the 3 digits used for versions, I figured
0.8.x would be a bugfix and fully version-compatible but I'm noticing newer
versions released w/ 4 digits which leads me to beleave there are less
guarantees between 0.8.0, 0.8.1.x and 0.8.2.x.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message