kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Madhukar Bharti <bhartimadhu...@gmail.com>
Subject Re: Issue with high level consumer in 8.1.1 after restart
Date Mon, 06 Apr 2015 17:49:51 GMT
Hi Mayuresh,

We are having only one consumer in the group and only one partition for
that topic.
We have set auto.commit.enable false, zookeeper.session.timeout.ms=60000,
rebalance.backoff.ms to 2000 and rebalance.max.retries to 20.

Thanks!

On Mon, Apr 6, 2015 at 9:59 PM, Mayuresh Gharat <gharatmayuresh15@gmail.com>
wrote:

> It actually depends on how many consumers you have in the same group and
> how many partitions the particular topic has.
>
> Can you elaborate on your configuration?
>
> Thanks,
>
> Mayuresh
>
> On Mon, Apr 6, 2015 at 3:35 AM, Madhukar Bharti <bhartimadhukar@gmail.com>
> wrote:
>
> > Hi All,
> >
> > We are facing issue with Kafka high Level consumers. We are using 0.8.1.1
> > version. Sometimes after restart consumers picks the messages sometimes
> it
> > starts but not receives any messages. Is high level consumer is not
> > reliable?
> >
> > I have checked with the log. Even if re-balance succeed, consumer didn't
> > receives any messages. Is there any way to overcome this.
> >
> > I am attaching log also when the consumer restarted. Please find the
> > attachment and let us know what can be possible reason. We have only one
> > partition for that topic.
> >
> > Thanks in Advance!
> >
>
>
>
> --
> -Regards,
> Mayuresh R. Gharat
> (862) 250-7125

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message