kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jiangjie Qin <j...@linkedin.com.INVALID>
Subject Re: High CPU usage for idle kafka server
Date Mon, 08 Jun 2015 20:07:47 GMT
It seems the attachments are lost. But high CPU for ReplicaRetcherThread might be related to
KAFKA-1461. Can you try to apply that patch and see if it solves problem?

Thanks,

Jiangjie (Becket) Qin

From: "pundlik.anuja" <pundlik.anuja@gmail.com<mailto:pundlik.anuja@gmail.com>>
Reply-To: "users@kafka.apache.org<mailto:users@kafka.apache.org>" <users@kafka.apache.org<mailto:users@kafka.apache.org>>
Date: Monday, June 8, 2015 at 12:20 PM
To: "users@kafka.apache.org<mailto:users@kafka.apache.org>" <users@kafka.apache.org<mailto:users@kafka.apache.org>>
Subject: Re: High CPU usage for idle kafka server

Seems to be LogCleaner and FetchRequest threads.
Attached is the profiling screenshot

On Fri, Jun 5, 2015 at 3:06 PM, Jiangjie Qin <jqin@linkedin.com.invalid<mailto:jqin@linkedin.com.invalid>>
wrote:
Has this to do with KAFKA-1461?
Can you see which thread is taking a lot of cpu? Some jconsole plugin can
get that information.

Jiangjie (Becket) Qin

On 6/5/15, 2:57 PM, "pundlik.anuja" <pundlik.anuja@gmail.com<mailto:pundlik.anuja@gmail.com>>
wrote:

>Hi Jay,
>
>Good to hear from you. I met you at the kafka meetup at linkedin.
>
>- No, I am running kafka_2.11-0.8.2.1
>
>
>Are there any logs/ any info that I can provide that will help you
>understand what could be the issue?
>
>Thanks,
>Anuja
>
>On Fri, Jun 5, 2015 at 2:36 PM, Jay Kreps <jay.kreps@gmail.com<mailto:jay.kreps@gmail.com>>
wrote:
>
>> This sounds a lot like a bug we fixed in 0.8.2.0, no chance you are
>>running
>> that pre-release version is there?
>>
>> -Jay
>>
>> On Wed, Jun 3, 2015 at 9:43 PM, Anuja Pundlik (apundlik) <
>> apundlik@cisco.com<mailto:apundlik@cisco.com>
>> > wrote:
>>
>> > Hi,
>> >
>> > I am using Kafka 0.8.2.1.
>> > We have 1 zookeeper, 3 kafka brokers.
>> > We have 9 topics, out of which 1 topic has 18 partitions, while
>>another
>> > has 12 partitions. All other topics have 1 partition each.
>> >
>> > We see that idle kafka brokers (not carrying any message) are using
>>more
>> > than 50% of CPU. See top output below.
>> >
>> > Is this a known issue?
>> >
>> >
>> > Thanks
>> >
>> >
>> >
>> > top - 04:42:30 up  2:07,  1 user,  load average: 1.50, 1.31, 0.92
>> > Tasks: 177 total,   1 running, 176 sleeping,   0 stopped,   0 zombie
>> > Cpu(s): 13.5%us,  4.5%sy,  0.0%ni, 81.3%id,  0.2%wa,  0.0%hi,  0.1%si,
>> > 0.4%st
>> > Mem:  65974296k total, 22310524k used, 43663772k free,   112688k
>>buffers
>> > Swap:        0k total,        0k used,        0k free, 13382460k
>>cached
>> >
>> >   PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+ COMMAND
>> >  9295 wae       20   0 5212m 894m  12m S   62  1.4  22:50.99 java
>> >  9323 wae       20   0 5502m 894m  12m S   56  1.4  24:28.69 java
>> >  9353 wae       20   0 5072m 896m  12m S   54  1.4  17:04.31 java
>> >
>>



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message