kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Gustafson <ja...@confluent.io>
Subject Re: Kafka + Avro serialization - io.confluent.kafka.serializers.KafkaAvroSerializer - maven dependency not resolving
Date Wed, 05 Aug 2015 22:39:56 GMT
Hey Neville, I tried just now and the artifact seems accessible. Perhaps
you can post your full pom to the mailing list that Grant linked to above
and we can investigate a bit more?

-Jason

On Wed, Aug 5, 2015 at 3:36 PM, Grant Henke <ghenke@cloudera.com> wrote:

> It looks like your usage lines up with the docs:
>
> http://docs.confluent.io/1.0/installation.html?highlight=maven#installation-maven
>
> You could try looking/asking on the Confluent Platform mailing list for
> support: https://groups.google.com/forum/#!forum/confluent-platform
>
> On Wed, Aug 5, 2015 at 5:28 PM, Neville Sequeira <
> neville.sequeira@gmail.com
> > wrote:
>
> > Maven repository http://packages.confluent.io/maven/ does not seem to be
> > working.
> >
> > I have these two blocks in my pom file...
> >
> > <repositories>
> >     <repository>
> >         <id>confluent</id>
> >         <url>http://packages.confluent.io/maven/</url>
> >     </repository>
> > </repositories>
> >
> >
> > <dependency>
> >     <groupId>io.confluent</groupId>
> >     <artifactId>kafka-avro-serializer</artifactId>
> >     <version>1.0</version> <!-- Also tried 2.0-SNAPSHOT  -->
> > </dependency>
> >
> >
> > Any work around for this? Any other Serializer implementation I can used
> > when using Avro with Kafka?
> >
> >
> > Thanks,
> > -Neville
> >
>
>
>
> --
> Grant Henke
> Software Engineer | Cloudera
> grant@cloudera.com | twitter.com/gchenke | linkedin.com/in/granthenke
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message