kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Loddengaard <a...@confluent.io>
Subject Re: Topic Deletion Issues
Date Tue, 05 Jan 2016 18:24:02 GMT
Hi Brenden, I sent the wrong permalink. Try this:

http://mail-archives.apache.org/mod_mbox/kafka-users/201512.mbox/%3CCAH7vnfhUQHQcCJ1R3pS_DYn0LvmA8fJtLtvCuvvDboWSqm-NBg%40mail.gmail.com%3E

Alex

On Tue, Jan 5, 2016 at 10:21 AM, Alex Loddengaard <alex@confluent.io> wrote:

> Hi Brenden, your previous email went through, and you got a response (that
> I believe answers your question). See here:
>
> http://mail-archives.apache.org/mod_mbox/kafka-users/201512.mbox/browser
>
> Alex
>
> On Mon, Jan 4, 2016 at 7:18 PM, Brenden Cobb <brendencobb@gmail.com>
> wrote:
>
>> I might have sent this recently, but was not able to receive mail from
>> this list (fixed)
>> ---
>>
>> Hello-
>>
>> We have a use case where we're trying to create a topic, delete, then
>> recreate with the same topic name.
>>
>> Running into inconsistant results.
>>
>> Creating the topic:
>> /opt/kafka/bin/kafka-topics.sh --create --partitions 3
>> --replication-factor 3 --topic test-01 --zookeeper zoo01:2181,
>> zoo02:2181, zoo03:2181
>>
>> Delete:
>> /opt/kafka/bin/kafka-topics.sh --delete --topic test-01 --zookeeper
>> zoo01:2181, zoo02:2181, zoo03:2181
>>
>> Repeat creation.
>>
>> The results are inconsistant. Executing the above several times can be
>> successful, then sporadically we get caught in "topic marked for
>> deletion" and it does not clear.
>>
>> This appears to be a Zookeeper issue of sorts as the logs will show:
>> [2015-12-30 22:32:32,946] WARN Conditional update of path
>> /brokers/topics/test-01/partitions/0/state with data
>>
>> {"controller_epoch":21,"leader":2,"version":1,"leader_epoch":1,"isr":[2,0,1]}
>> and expected version 1 failed due to
>> org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode
>> = NoNode for /brokers/topics/test-01/partitions/0/state
>> (kafka.utils.ZkUtils$)
>>
>> In this instance no subdirectories exist beyond /brokers/topics/test-01
>>
>> I'd like to know if this is a common occurrance and why the Zookeeper
>> node isn't "fully" created as Kafka deletion seems stuck without the
>> expected node path.
>>
>> We are using Kafka 8.2. Purging is also an option (if achievable
>> programmatically), we just need to make sure there are no messages
>> left when resuming the producer.
>>
>> Appreciate any info/guidance.
>>
>> Thanks,
>> BC
>>
>
>
>
> --
> *Alex Loddengaard | **Solutions Architect | Confluent*
> *Download Apache Kafka and Confluent Platform: www.confluent.io/download
> <http://www.confluent.io/download>*
>



-- 
*Alex Loddengaard | **Solutions Architect | Confluent*
*Download Apache Kafka and Confluent Platform: www.confluent.io/download
<http://www.confluent.io/download>*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message