kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Peterson <d...@academia.edu>
Subject trouble upgrading from 0.8.2.1 to 0.9.0.0: invalid message
Date Fri, 15 Jan 2016 02:04:14 GMT
I was trying to upgrade an 0.8.2.1 broker cluster to 0.9.0.0 by following
the instructions here:

    http://kafka.apache.org/documentation.html#upgrade

After upgrading one broker, with inter.broker.protocol.version=0.8.2.X
set, I get ACK error 2 (InvalidMessage) when I try to send produce
requests.  When I revert the broker to 0.8.2.1 the errors go away.  Has
anyone run into this problem, or have any suggestions?

Thanks,
Dave

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message