kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 0xAB AB <xababa...@gmail.com>
Subject Error reading field 'brokers'
Date Wed, 11 May 2016 15:05:08 GMT
Hi,

I am using kafka version e20eba958d8de29cb4e3b6feea37ac3a1e1ab4f9
(something which identifies as 0.10.0-SNAPSHOT when built), which gives me

files like

./repository/org/apache/kafka/kafka-tools/0.10.1.0-SNAPSHOT/kafka-tools-0.10.1.0-SNAPSHOT.jar
and

./repository/org/apache/kafka/kafka_2.11/0.10.1.0-SNAPSHOT
./repository/org/apache/kafka/kafka_2.11/0.10.1.0-SNAPSHOT/kafka_2.11-0.10.1.0-SNAPSHOT-javadoc.jar
./repository/org/apache/kafka/kafka_2.11/0.10.1.0-SNAPSHOT/kafka_2.11-0.10.1.0-SNAPSHOT-scaladoc.jar
./repository/org/apache/kafka/kafka_2.11/0.10.1.0-SNAPSHOT/kafka_2.11-0.10.1.0-SNAPSHOT-sources.jar
./repository/org/apache/kafka/kafka_2.11/0.10.1.0-SNAPSHOT/kafka_2.11-0.10.1.0-SNAPSHOT-test-sources.jar
./repository/org/apache/kafka/kafka_2.11/0.10.1.0-SNAPSHOT/kafka_2.11-0.10.1.0-SNAPSHOT-test.jar
./repository/org/apache/kafka/kafka_2.11/0.10.1.0-SNAPSHOT/kafka_2.11-0.10.1.0-SNAPSHOT.jar
./repository/org/apache/kafka/kafka_2.11/0.10.1.0-SNAPSHOT/kafka_2.11-0.10.1.0-SNAPSHOT.pom
./repository/org/apache/kafka/kafka_2.11/0.10.1.0-SNAPSHOT/maven-metadata-local.xml

which I use in SBT like:

libraryDependencies += "org.apache.kafka" %% "kafka" % "0.10.1.0-SNAPSHOT"

libraryDependencies += "org.apache.kafka" % "kafka-tools" % "0.10.1.0-SNAPSHOT"


which in turn gets me when reading from a 0.9.0.1 host the following:

[image: Inline image 2]
When I run the ConsoleConsumer directly from trunk there is no problem.
Only when I run my forked version, which uses the exact same code, but the
locally built dependencies, I get the above.

Can someone tell me why I get the above error message?

Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message