kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stevo Slavić <ssla...@gmail.com>
Subject Re: Streams dependency on RocksDB - licenses
Date Tue, 26 Sep 2017 07:49:12 GMT
There is legal problem for older rocksdb versions, see
https://issues.apache.org/jira/browse/LEGAL-303?focusedCommentId=16109870&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-16109870

Dependencies with Facebook BSD+Patents license are not allowed to be
included in Apache products
https://www.apache.org/legal/resolved.html#category-x

I see even latest trunk depends on older rocksdb 5.3.6
https://github.com/apache/kafka/blob/trunk/gradle/dependencies.gradle#L67

Please consider upgrading, maybe as critical for 1.0.0 release if possible.
Should I create the ticket?

Kind regards,
Stevo Slavic.

On Thu, Sep 21, 2017 at 5:22 PM, Ismael Juma <ismael@juma.me.uk> wrote:

> This commit says that GPLv2 is an alternative license, so it's all good, I
> believe:
>
> https://github.com/facebook/rocksdb/commit/d616ebea23fa88cb9c2c8588533526
> a566d9cfab
>
> Ismael
>
> On Thu, Sep 21, 2017 at 4:21 PM, Ismael Juma <ismael@juma.me.uk> wrote:
>
> > LevelDB is New BSD (and the license in the first commit you linked to is
> > definitely not GPL2):
> >
> > https://github.com/google/leveldb/blob/master/LICENSE
> >
> > The second commit you referenced, adds GPL2 to the list of licenses in
> the
> > pom, but it's not clear why.
> >
> > Ismael
> >
> > On Thu, Sep 21, 2017 at 3:44 PM, Stevo Slavić <sslavic@gmail.com> wrote:
> >
> >> LevelDB GPL2 notice seems to have been added to rocksdb 5.7.1, but
> likely
> >> this applies to old versions too.
> >>
> >> https://github.com/facebook/rocksdb/commit/4a2e4891fe4c6f66f
> >> b9e8e2d29b04f46ee702b52#diff-7e1d2c46cd6eacd9a8d864450a128218
> >> https://github.com/facebook/rocksdb/commit/6e3ee015fb1ce03e4
> >> 7838e9a3995410ce884c212#diff-1d5a1a614aa158e14292a60d9891f1df
> >>
> >> Shouldn't similar notice be added to Apache Kafka too?
> >>
> >> On Thu, Sep 21, 2017 at 3:43 PM, Stevo Slavić <sslavic@gmail.com>
> wrote:
> >>
> >> > Hello Apache Kafka community,
> >> >
> >> > Is it on purpose that kafka-streams 0.11.0.1 depends on
> >> > org.rocksdb:rocksdbjni:5.0.1, and not on newer 5.7.3, because 5.0.1
> has
> >> > Apache 2 license while 5.7.3 has also GPL 2.0 parts?
> >> >
> >> > Kind regards,
> >> > Stevo Slavic.
> >> >
> >>
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message