kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jakub Scholz <ja...@scholz.cz>
Subject Re: one machine that have four network.....
Date Tue, 16 Jan 2018 13:40:57 GMT
To be honest, I'm not familiar enough with the network configuration etc.
But the advice from Svante looks like it might give some idea how to fix it.

Regards
Jakub

On Tue, Jan 16, 2018 at 2:08 PM, 猪少爷 <zhurongjie0416@foxmail.com> wrote:

> Jakhub:  I would like to increase the bandwidth by binding each broke to
> each network card in one machine. Is this feasible?
>
>
>
>
> ------------------ 原始邮件 ------------------
> 发件人: "猪少爷";<zhurongjie0416@foxmail.com>;
> 发送时间: 2018年1月16日(星期二) 上午10:14
> 收件人: "users"<users@kafka.apache.org>;
>
> 主题: one machine that have four network.....
>
>
>
> hi guys,
>          I have a linux(Centos7) that have four network interface,  and
> i'm tryying  to build a pseudo-cluster in this machine.
> Four cards correspond to four ip(101, 104,105,106),
> and three brokers config :
> listeners=xxx.xxx.xxx.104:9090.
> listeners=xxx.xxx.xxx.105:9091.
> listeners=xxx.xxx.xxx.106:9092.
> three zookeepers: zk1---xxx.104:2181, zk2---xxx:105:2182,
> zk3---xxx.106:2183.
>
>
> run zks first, then run in right.
> run kafka broker,  then  run in  right.
>
>
> produce data to this to this pseudo-cluster...Trouble is coming:
>
>
> sar -n DEV 1:
> network-101-- IO(0-1000Mbps)
> network-104-- IO(0-10Kbps)
> network-105-- IO(0-10kbps)
> network-106-- IO(0-10Kbps)
> lo---IO(0-1000Mbps)
>
>
> When production data throughput reaches 1000 Mbps, reproduction fails,Then
> unplug the network cable of 101. continue:
>
>
> sar -n DEV 1:
> network-101-- IO(0bps)
> network-104-- IO(0-10Kbps)
> network-105-- IO(0-10kbps)
> network-106-- IO(0-1000Mbps)
> lo---IO(0-1000Mbps)
>
>
>
> what happens, and why??
> Would you like to give me some advice, guys?
>
>
> Urgent, online and so on
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message