kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andras Beni <andrasb...@cloudera.com>
Subject Re: Kafka 0.8.2 Producers -> Kafka Brokers 0.9.x
Date Tue, 27 Feb 2018 06:24:50 GMT
Hi Waleed,

generally extra work is necessary only when the client uses a different
message format version than what is used in the broker log. Then the broker
has to convert between those formats.
In case of 0.8 and 0.9 there is no difference in the message format: both
use version 0.

Best regards,
Andras


On Sat, Feb 24, 2018 at 7:19 PM, Waleed Fateem <waleed.fateem@gmail.com>
wrote:

> Hello!
>
> This is a very general question but I was wondering if anyone knows whether
> or not the Kafka brokers need to do any additional work to receive/respond
> to requests coming in from older clients.
>
> Even though newer brokers support older clients, is there any additional
> processing time that can be incurred because of the version mismatch. I'm
> specifically curious about the Kafka brokers 0.9.x responding to Kafka
> clients 0.8.2.
>
> Thank you.
>
> Waleed
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message