kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From adrien ruffie <adriennolar...@hotmail.fr>
Subject RE: kafka offset replication factor - Any suggestion will be appreciated.
Date Thu, 22 Mar 2018 15:53:58 GMT
Are you sure on which kafka cluster & zookeeper cluster you have launched "describe" command
?


Because you first log trace is "ERROR [KafkaApi-0] ..."


and your second is "[kfk01] ..."

________________________________
De : Anand, Uttam <Uttam.Anand@BNSF.com>
Envoyé : jeudi 22 mars 2018 16:39:51
À : users@kafka.apache.org
Objet : RE: kafka offset replication factor - Any suggestion will be appreciated.

I checked already. Topic is having replication factor as 1 only.

[kfk01]$ bin/kafka-topics.sh --describe --zookeeper localhost:2181 --topic test
Topic:test      PartitionCount:52       ReplicationFactor:1     Configs:


-----Original Message-----
From: adrien ruffie [mailto:adriennolarsen@hotmail.fr]
Sent: Thursday, March 22, 2018 2:28 AM
To: users@kafka.apache.org
Subject: RE: kafka offset replication factor - Any suggestion will be appreciated.

<center><p style="color:red; font-size:24px;"><b>EXTERNAL EMAIL</b></p></center>
Hi,

have you check if you have already not created a old topic with this replication factor '3'
? You can check it by listing with the command kafka-topcis.sh -- zookeeper ip:port --describe/list


Best regards,


Adrien

________________________________
De : Anand, Uttam <Uttam.Anand@BNSF.com> Envoyé : mercredi 21 mars 2018 22:25:16 À
: users@kafka.apache.org Objet : kafka offset replication factor - Any suggestion will be
appreciated.

Hi ,

I am getting an issue while producing and consuming messages. I have just one kafka broker
and one zookeeper. So I have given replication factor of all topics as 1.
I don't know from where is it trying to get replication factor as 3.


In my server.properties file I have already defined -:

offsets.topic.replication.factor=1
transaction.state.log.replication.factor=1
transaction.state.log.min.isr=1


[2018-03-21 15:54:28,249] ERROR [KafkaApi-0] Number of alive brokers '1' does not meet the
required replication factor '3' for the offsets topic (configured via 'offsets.topic.replication.factor').
This error can be ignored if the cluster is starting up and not all brokers are up yet. (kafka.server.KafkaApis)



Thanks
Uttam

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message