kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 刘鹏 <byrliup...@163.com>
Subject Error reading field 'version' when execute kafka-consumer-groups.sh
Date Wed, 08 Aug 2018 12:04:39 GMT
hi,
    I get an error when I run kafka-consumer-groups.sh.


    firstly,I run:
    ./kafka-consumer-groups.sh --command-config consumer.properties --bootstrap-server ip:port
--list
   
    the result is:
    Note: This will not show information about old Zookeeper-based consumers.
    mygroup
    
    then,I run:
   ./kafka-consumer-groups.sh --command-config consumer.properties --bootstrap-server ip:port
--describe --group mygroup


   the output I get is:
   Note: This will not show information about old Zookeeper-based consumers.
   Error: Executing consumer group command failed due to Error reading field 'version': java.nio.BufferUnderflowException


   my kafka version is:2.11-1.1.0,zookeeper version is:3.4.6,I have a 5 nodes zk cluster and
a 5 node kafka brokers cluster,they are in the same 5 machine.I am using sarama-cluster as
kafka client in golang.


   How can I find more detail of the error? Is anyone have some idea when this error occur?



   thanks a lot.




thank you
liupeng

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message