kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "M. Manna" <manme...@gmail.com>
Subject Re: Kafka on Eclipse Setup
Date Sat, 13 Oct 2018 09:14:47 GMT
I have done the following and it worked for me.

1) Manually removed and added the jar locations in eclipse run
configuration e.g. client, core, etc.
2) Added program argument for log4j file and server properties, and
zookeeper properties.
3) Started zookeeper first
4) Then started Kafka.

I never had any problem with Zookeeper, so I actually ran
zookeeper-server-start script to start zookeeper manually. In this way, I
only need to start Kafka in debug mode from Eclipse.

Let me know if that helps.



On Sat, 13 Oct 2018 at 02:49, James Kwan <jwkwan2000@gmail.com> wrote:

> Has anyone successfully set up an eclipse environment for Kafka on
> Windows?  I have tried many times with different options but still have
> build issues with stream project.  There are always some libraries
> missing.
>
> The steps I used
> 1) Run git command in command prompt to download the Kafka.  I used
> windows command as well as using eclipse GIT options
> 2) Run gradle command to build the base.
> 3) Run gradlew jar to build the jar file
> 4) Run gradlew eclipse command to build projects
> 5) In eclipse, use Import/General/Existing Projects into Workspace option
> to import all projects
> 6) Remove duplicate source entries in build path for core project
> 7) Remove test projects that caused not found error message in the build
> path for core project
> 8) Remove the dependence of test-utils lib in stream project build path to
> remove the build cycle error.
> 9) after that I got whole bunch of class or path not defined messages.  I
> don’t know if I need to fix them one by one or if there is any jar files
> that I need to include.
>
>
> James

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message