kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias J. Sax" <matth...@confluent.io>
Subject Re: kafka client 1.1.0 broker compatibility
Date Mon, 22 Oct 2018 20:14:31 GMT
If Logstash's internal client is 1.1.0, it is be compatible with Kafka
brokers 2.0.0.

Note: Brokers are always backward compatible to older clients (your
case). Additionally, since, 0.10.0.0 release, broker are also forward
compatible to newer clients.


-Matthias

On 10/22/18 4:06 AM, Dayananda S wrote:
> Looking for an updated broker compatibility chart for Kafka client 1.1.0.
> 
> Basically kafka input plugin for Logstash uses kafka client 1.1.0 and I wanted to check
if this plugin supports kafka broker v2(latest version)
> 
> Disclaimer <http://www.kbc.com/KBCmailDisclaimer>
> 


Mime
View raw message