kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nikhil Bhaware <nikhilbhaware...@gmail.com>
Subject Re: Replica Fetcher errors for Deleted topics
Date Tue, 06 Nov 2018 19:56:40 GMT
Rolling restart fixed the problem in my case.

On Tue, Nov 6, 2018 at 3:54 PM Avinash Shahdadpuri <avinashpuri@gmail.com>
wrote:

> Hi,
>
> We are seeing a weird behavior for deleted topics on our cluster. Broker
> logs have following messages, the cluster appears to be healthy except for
> these messages.
>
> ERROR [ReplicaFetcher replicaId=1, leaderId=5, fetcherId=0] Error for
> partition deleted-topic-20 to broker
> 5:org.apache.kafka.common.errors.UnknownTopicOrPartitionException: This
> server does not host this topic-partition.
> (kafka.server.ReplicaFetcherThread)
>
> My first instinct was topic deletion failed. It indeed was the case, the
> broker dirs were deleted but zookeeper nodes still existed.
>
> I went and deleted zookeeper nodes
>
> delete /config/topics/<topic_name> delete /brokers/topics/<topic_name>
> delete /admin/delete_topics/<topic_name>
>
> No client application is trying to access these topics. We still see the
> errors like these
>
> ERROR [ReplicaFetcher replicaId=1, leaderId=5, fetcherId=0] Error for
> partition deleted-topic-20 to broker
> 5:org.apache.kafka.common.errors.UnknownTopicOrPartitionException: This
> server does not host this topic-partition.
> (kafka.server.ReplicaFetcherThread)
>
> Has anyone run into this issue?
>
> What would be the best way to resolve this?
>
> Thanks,
>
> Avinash
>


-- 
Regards ,
Nikhil Bhaware
M.Tech (CSE)
NIT Warangal,India

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message