kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dayananda S <dayanand...@kbc.be>
Subject RE: kafka client 1.1.0 broker compatibility
Date Wed, 14 Nov 2018 10:16:51 GMT
Hi ,
I am looking to upgrade Kafka from 0.10.2 to version 2. Documentation in kafka website says
editing server.properties file and upgrade the code. I understood the editing part of server.peroperties
file. But what is meant by upgrade the code or upgrade kafka ? is it just replacing kafka
binaries? Or anything else needs to be done.


-----Original Message-----
From: Matthias J. Sax <matthias@confluent.io> 
Sent: 22 October 2018 22:15
To: users@kafka.apache.org
Subject: Re: kafka client 1.1.0 broker compatibility

If Logstash's internal client is 1.1.0, it is be compatible with Kafka brokers 2.0.0.

Note: Brokers are always backward compatible to older clients (your case). Additionally, since,
0.10.0.0 release, broker are also forward compatible to newer clients.


-Matthias

On 10/22/18 4:06 AM, Dayananda S wrote:
> Looking for an updated broker compatibility chart for Kafka client 1.1.0.
> 
> Basically kafka input plugin for Logstash uses kafka client 1.1.0 and 
> I wanted to check if this plugin supports kafka broker v2(latest 
> version)
> 
> Disclaimer <http://www.kbc.com/KBCmailDisclaimer>
> 


Disclaimer <http://www.kbc.com/KBCmailDisclaimer>


Mime
View raw message