kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pradeep bansal <bpradee...@gmail.com>
Subject Re: Kafka compatible with Java 11?
Date Fri, 01 Feb 2019 01:24:18 GMT
I am receiving below warnings when running kafka-acl and other tools which
interact with zookeeper.

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by
org.apache.zookeeper.server.util.KerberosUtil
(file://apache/kafka/kafka_2.11-2.1.0/libs/zookeeper-3.4.13.jar) to
method sun.security.krb5.Config.getInstance()
WARNING: Please consider reporting this to the maintainers of
org.apache.zookeeper.server.util.KerberosUtil
WARNING: Use --illegal-access=warn to enable warnings of further
illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release


On Fri, Feb 1, 2019 at 4:43 AM M. Manna <manmedia@gmail.com> wrote:

> The new release is compatible, doesn’t that work for you ?
>
> On Thu, 31 Jan 2019 at 22:58, pradeep bansal <bpradeep20@gmail.com> wrote:
>
> > Can we have kafka compatible with Java 11. Also, currently some library
> > dependencies like zookeeper  are not compatible with Java 11.
> >
> > It will be a great help if we have this available given that changes to
> > Java that are going on currently.
> >
> > Thanks,
> > Pradeep
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message