kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Anderson <manderso...@gmail.com>
Subject Re: Kafka 2.2.1 with Zookeeper 3.5.5
Date Wed, 05 Jun 2019 20:47:14 GMT
Kafka has its own version of the zookeeper client libraries that are still
3.4.13.

I'd be interested to know if it is compatible with 3.5.x now that has a
stable release.

Mark

On Wed, 5 Jun 2019, 21:27 Sebastian Schmitz, <
sebastian.schmitz@propellerhead.co.nz> wrote:

> Hi,
>
> I am currently testing the new Kafka 2.2.1 with new Zookeeper 3.5.5 on
> my local machine to see if we can upgrade the other environments with it.
>
> During startup of Kafka it shows Zookeeper-Version as 3.4.13:
>
> [2019-06-05 20:16:41,486] INFO Client
> environment:zookeeper.version=3.4.13-2d71af4dbe22557fda74f9a9b4309b15a7487f03,
>
> built on 06/29/2018 00:39 GMT (org.apache.zookeeper.ZooKeeper)
>
> So I wonder why it shows the old version while the Zookeeper shows it's
> version as 3.5.5:
>
> 2019-06-05 20:16:36,742 [myid:1] - INFO  [main:Environment@109] - Server
> environment:zookeeper.version=3.5.5-390fe37ea45dee01bf87dc1c042b5e3dcce88653,
>
> built on 05/03/2019 12:07 GMT
>
> There's only one Kafka-broker with one Zookeeper, so it's not connecting
> to something else...
>
> Thanks
>
> Sebastian
>
>
> --
> DISCLAIMER
> This email contains information that is confidential and which
> may be
> legally privileged. If you have received this email in error please
>
> notify the sender immediately and delete the email.
> This email is intended
> solely for the use of the intended recipient and you may not use or
> disclose this email in any way.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message