kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From SenthilKumar K <senthilec...@gmail.com>
Subject Re: Kafka Partition Leader -1
Date Mon, 11 Nov 2019 06:21:47 GMT
Thanks.

Keeping Broker iD 0 has caused some problems for me in the past ==>  Our
brokers start with id 1.  Refer the attached image.


you mentioned you “Fixed the broker” in the past. What exactly did you fix?
- broker restart helped.


On Fri, Nov 8, 2019 at 5:08 AM M. Manna <manmedia@gmail.com> wrote:

> Hi,
>
> On 7 Nov 2019, at 09:18, SenthilKumar K <senthilec566@gmail.com> wrote:
>
> Hello Experts ,  We are observing issues in Partition(s) when the Kafka
> broker is down & the Partition Leader Broker ID set to -1.
>
> Kafka Version 2.2.0
> Total No Of Brokers: 24
> Total No Of Partitions: 48
> Replication Factor: 2
> Min In sync Replicas: 1
>
>
> Partition                                             Leader
>  Replicas           In Sync Replicas
> [image: Screen Shot 2019-11-07 at 2.20.34 PM.png]
> See above the Partition 41 leader set to -1 ,  the replicas exist in
> 18,24. The broker id 24 went down for due to Too many open files.
>
> Q: Why is it not electing the broker 18 as a leader for Partition 41?
>
> Had a similar problem in Past, after fixing the broker the partition shows
> correct leader.
>
> Kafka Properties:
> default.replication.factor = 2
>
> unclean.leader.election.enable = true
>
> min.insync.replicas = 1
>
> num.partitions = 48
>
>
> Zookeeper Active Broker ID's:
> [zk: localhost:2181(CONNECTED) 1] ls /kafka.test/brokers/ids
> [1, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 3, 4, 5, 6, 7,
> 8, 9]
>
> [zk: localhost:2181(CONNECTED) 2]
>
> Restarting ZK also didn't help.
>
> Pls advise! How to fix this? Why is this happening?
>
> Your attachment image didn’t come through. Also, not sure what’s your ID
> assignment strategy is, Keeping Broker iD 0 has caused some problems for me
> in the past. With ID >=1 I haven’t had any issue as such.
>
> Also, you mentioned you “Fixed the broker” in the past. What exactly did
> you fix?
>
> Regards,
>
>
>
>

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message