kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruno Cadonna <br...@confluent.io>
Subject Re: Can not compile kafka
Date Thu, 14 Nov 2019 10:40:45 GMT
Hi Miguel,

I build Kafka with Gradle 5.2.1 and at the end of the build I get the
following message:

"Deprecated Gradle features were used in this build, making it
incompatible with Gradle 6.0."

So, maybe you ran in one of those incompatibilities.

Try to compile with a 5.x version of Gradle.

Best,
Bruno

On Thu, Nov 14, 2019 at 10:59 AM Miguel Silvestre <msilvestre@gmail.com> wrote:
>
> Hi,
>
> I'm on macOS Mojave 10.14.6 but when I run gradle (I'm using version 6.0) I
> get the following error:
>
> What can I do?
>
> FAILURE: Build failed with an exception.
>
> * Where:
> Build file '/Users/miguel.silvestre/Projects/others/kafka/build.gradle'
> line: 480
>
> * What went wrong:
> A problem occurred evaluating root project 'kafka'.
> > Could not create task ':clients:spotbugsMain'.
>    > Could not create task of type 'SpotBugsTask'.
>       > Could not create an instance of type
> com.github.spotbugs.internal.SpotBugsReportsImpl.
>          >
> org.gradle.api.reporting.internal.TaskReportContainer.<init>(Ljava/lang/Class;Lorg/gradle/api/Task;)V
>
> * Try:
> Run with --stacktrace option to get the stack trace. Run with --info or
> --debug option to get more log output. Run with --scan to get full insights.
>
> * Get more help at https://help.gradle.org
>
> Deprecated Gradle features were used in this build, making it incompatible
> with Gradle 7.0.
> Use '--warning-mode all' to show the individual deprecation warnings.
> See
> https://docs.gradle.org/6.0/userguide/command_line_interface.html#sec:command_line_warnings
>
> BUILD FAILED in 2s
> --
> Miguel Silvestre

Mime
View raw message