kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ashutosh singh <getas...@gmail.com>
Subject Partition Reassignment is getting stuck
Date Wed, 13 Nov 2019 12:40:30 GMT
Hi,

All of a  sudden I see under replicated partition in our Kafka cluster and
it is not getting replicated.  It seems it is getting stuck somewhere. In
sync replica is missing only form one of the broker it seems there is some
issue with that broker but other hand there are many others topic on that
node and they are working fine.  I have tried rolling restart of all the
nodes in cluster but that didn't help.
I tried manual reassignment of that particular topic but that is getting
stuck forever.  So I had to kill the reassignment by deleting
/admin/reassign_partitions  node.  I restarted zookeeper so that leader
gets change and then tried to reassign partitions but again it is getting
stuck.

I really appreciate if someone can help to understand the issue.

No of nodes : 8
Version : 2.1.1

-- 
Thanks
Ashu

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message