karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charles Moulliard <cmoulli...@gmail.com>
Subject Re: Equinox packages
Date Mon, 22 Nov 2010 08:05:51 GMT
Hi Lukasz,

According to Equinox documentation 
(http://www.eclipse.org/equinox/incubator/aspects/equinox-aspects-quick-start.php), 
the following bundles are required :

# /org.eclipse.osgi/ (The system bundle)
# /org.eclipse.equinox.weaving.hook/ (Must be co-located with the system 
bundle!)
# /org.eclipse.equinox.weaving.aspectj/
# /org.aspectj.runtime/
# /org.aspectj.weaver/

The other are optional

I don't know what they would like to say but it seems that the system 
fragment /org.eclipse.equinox.weaving.hook /must be placed after the 
system bundle ! Try to change the bundle start level of this bundle to 
have a lowest value as this is the case with the system bundle.

Regards,

Charles
On 21/11/10 21:59, Ɓukasz Dywicki wrote:
> Aspect Weaving Hooks Plug-in

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message