karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject [DISCUSS] Refactoring of maven plugins
Date Mon, 07 Feb 2011 10:30:35 GMT
Hi all,

I'm beginning to work on KARAF-402.

The purpose is to gather all goals available into one central maven 
plugin and, later, extend this plugin with new goals depending of 
current opened discussions (run, profiles, etc :)).

I think that the tooling groupId is not more required as we will have 
only one maven plugin.

So I propose the following naming convention:
groupId: org.apache.karaf
artifactId: karaf-maven-plugin.

So for the users, the POM definition will look like:

<plugins>
	<plugin>
		<groupId>org.apache.karaf</groupId>
		<artifactId>karaf-maven-plugin</artifactId>
		<version>3.0.0</version>
		<executions>
			<execution>
				<id>add-features-to-repo</id>
				<phase>generate-resources</phase>
				<goals>
					<goal>add-features-to-repo</goal>
				</goals>
				[...]
			</execution>
		</executions>
	</plugin>
</plugins>

I think it's clear for the users.

The question is now more on tooling/testing module.

This tooling/testing module should be moved on the trunk root too.
We have to ways to see that:
1/ I move tooling/testing logic in itests modules (but maybe it 
introduces circular dependencies, I have to check)
2/ I create a new testing project dedicated to the itests of maven plugin

WDYT ?

Regards
JB

Mime
View raw message