karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From " Jean-Baptiste Onofré" ...@nanthrax.net>
Subject Re: Dropping support for jdk 1.5 in Karaf 3.0 - https://issues.apache.org/jira/browse/KARAF-328
Date Fri, 06 May 2011 13:29:11 GMT
Thanks Christian,

I will review it and apply.

Regards
JB

On Fri 06/05/11 13:25 , Christian Schneider  wrote::

I have changed the source and target version for the maven compiler 
plugin to 1.6 and
added the enforcer plugin to enforce maven 3.0.2 and jdk 1.6.

https://issues.apache.org/jira/browse/KARAF-328

Christian


Am 06.05.2011 10:53, schrieb  Jean-Baptiste Onofré:
> Hi Christian,
>
> it's the plan: Karaf 3.0 will only support JDK 1.6 and Maven3.
>
> On my side, I began to start of the Maven refactoring (using maven-invoker in place of
maven-embedder, and I raised the corresponding Jira).
>
> I also propose to use the enforcer maven plugin to check the Maven and JDK version used
on trunk and branches.
>
> Regards
> JB
>
>
> On Fri 06/05/11 10:47 , Christian Schneider  wrote::
>
> Hi all,
>
> I am currently investigating issue
> https://issues.apache.org/jira/browse/KARAF-328>
>
> I have seen that the current settings for the maven compiler plugin are
> source and target 1.4. So I think we need to bump this to 1.6.
>
> Is there any more that needs to be done to solve this issue?
>
> Christian
>

-- 
Christian Schneider
http://www.liquid-reality.de

CXF and Camel Architect





Mime
View raw message