karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charles Moulliard <cmoulli...@gmail.com>
Subject Zip error when deploying webconsole wicket
Date Thu, 08 Sep 2011 12:11:29 GMT
Hi,

I get this error when deploying webconsole wicket on karaf 2.2

14:07:23,382 | INFO  | l Console Thread | Console
    | araf.shell.console.jline.Console  258 | 25 -
org.apache.karaf.shell.console - 2.2.2 | Exception caught while
executing command
org.osgi.framework.BundleException: Unable to cache bundle:
mvn:org.apache.karaf.webconsole/org.apache.karaf.webconsole.karaf/1.0.0-SNAPSHOT
	at org.apache.felix.framework.Felix.installBundle(Felix.java:2487)[org.apache.felix.framework-3.0.9.jar:]
	at org.apache.felix.framework.Felix.installBundle(Felix.java:2443)[org.apache.felix.framework-3.0.9.jar:]
	at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:129)[org.apache.felix.framework-3.0.9.jar:]
	at org.apache.karaf.features.internal.FeaturesServiceImpl.installBundleIfNeeded(FeaturesServiceImpl.java:691)[26:org.apache.karaf.features.core:2.2.2]
	at org.apache.karaf.features.internal.FeaturesServiceImpl.doInstallFeature(FeaturesServiceImpl.java:475)[26:org.apache.karaf.features.core:2.2.2]
	at org.apache.karaf.features.internal.FeaturesServiceImpl.doInstallFeature(FeaturesServiceImpl.java:453)[26:org.apache.karaf.features.core:2.2.2]
	at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:292)[26:org.apache.karaf.features.core:2.2.2]
	at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:280)[26:org.apache.karaf.features.core:2.2.2]
	at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:276)[26:org.apache.karaf.features.core:2.2.2]
	at org.apache.karaf.features.command.InstallFeatureCommand.doExecute(InstallFeatureCommand.java:62)[22:org.apache.karaf.features.command:2.2.2]
	at org.apache.karaf.features.command.FeaturesCommandSupport.doExecute(FeaturesCommandSupport.java:39)[22:org.apache.karaf.features.command:2.2.2]
	at org.apache.karaf.shell.console.OsgiCommandSupport.execute(OsgiCommandSupport.java:38)[25:org.apache.karaf.shell.console:2.2.2]
	at org.apache.felix.gogo.commands.basic.AbstractCommand.execute(AbstractCommand.java:35)[25:org.apache.karaf.shell.console:2.2.2]
	at org.apache.felix.gogo.runtime.CommandProxy.execute(CommandProxy.java:78)[25:org.apache.karaf.shell.console:2.2.2]
	at org.apache.felix.gogo.runtime.Closure.executeCmd(Closure.java:474)[25:org.apache.karaf.shell.console:2.2.2]
	at org.apache.felix.gogo.runtime.Closure.executeStatement(Closure.java:400)[25:org.apache.karaf.shell.console:2.2.2]
	at org.apache.felix.gogo.runtime.Pipe.run(Pipe.java:108)[25:org.apache.karaf.shell.console:2.2.2]
	at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:183)[25:org.apache.karaf.shell.console:2.2.2]
	at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:120)[25:org.apache.karaf.shell.console:2.2.2]
	at org.apache.felix.gogo.runtime.CommandSessionImpl.execute(CommandSessionImpl.java:79)[25:org.apache.karaf.shell.console:2.2.2]
	at org.apache.karaf.shell.console.jline.Console.run(Console.java:240)[25:org.apache.karaf.shell.console:2.2.2]
	at java.lang.Thread.run(Thread.java:680)[:1.6.0_26]
Caused by: java.util.zip.ZipException: invalid CEN header (bad signature)
	at java.util.zip.ZipFile.open(Native Method)[:1.6.0_26]
	at java.util.zip.ZipFile.<init>(ZipFile.java:127)[:1.6.0_26]
	at java.util.zip.ZipFile.<init>(ZipFile.java:144)[:1.6.0_26]
	at org.apache.felix.framework.util.ZipFileX.<init>(ZipFileX.java:36)[org.apache.felix.framework-3.0.9.jar:]
	at org.apache.felix.framework.util.SecureAction.openZipFile(SecureAction.java:607)[org.apache.felix.framework-3.0.9.jar:]
	at org.apache.felix.framework.cache.JarRevision.<init>(JarRevision.java:89)[org.apache.felix.framework-3.0.9.jar:]
	at org.apache.felix.framework.cache.BundleArchive.createRevisionFromLocation(BundleArchive.java:862)[org.apache.felix.framework-3.0.9.jar:]
	at org.apache.felix.framework.cache.BundleArchive.reviseInternal(BundleArchive.java:549)[org.apache.felix.framework-3.0.9.jar:]
	at org.apache.felix.framework.cache.BundleArchive.<init>(BundleArchive.java:148)[org.apache.felix.framework-3.0.9.jar:]
	at org.apache.felix.framework.cache.BundleCache.create(BundleCache.java:251)[org.apache.felix.framework-3.0.9.jar:]
	at org.apache.felix.framework.Felix.installBundle(Felix.java:2483)[org.apache.felix.framework-3.0.9.jar:]

Regards,
Charles Moulliard

Apache Committer

Blog : http://cmoulliard.blogspot.com
Twitter : http://twitter.com/cmoulliard
Linkedin : http://www.linkedin.com/in/charlesmoulliard
Skype: cmoulliard

Mime
View raw message