karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Schneider <ch...@die-schneider.net>
Subject Re: Simpler karaf shell command/action definition
Date Wed, 09 May 2012 16:16:17 GMT
I think the namespace could be made a bit simpler by only using:

<shell:action class="..">
<completer ref=""/>

So we could skip the command-bundle and we could skip the command.

Additionally it would be great to be able to inject the same 
dependencies into more than one action. Like the parent attribute in 
spring beans.

Currently for example if we have a service that all commands of a type 
use we have to inject it into each.


Am 09.05.2012 18:05, schrieb Guillaume Nodet:
> That's what we the namespace handler does.  The<action/>  are actually
> templates.
> The service publishing is needed at some point so that the shell knows
> about the commands.
> I don't really understand how you can really simply the minimum definition
> we have now:
>      <command-bundle xmlns="http://karaf.apache.org/xmlns/shell/v1.0.0">
>          <command>
>              <action class="..."/>
>          </command>
>      </command-bundle>


Christian Schneider

Open Source Architect
Talend Application Integration Division http://www.talend.com

View raw message