karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Achim Nierbeck <bcanh...@googlemail.com>
Subject Re: Add a scope feature-url
Date Fri, 25 May 2012 21:49:25 GMT
Christian,

basically I just can repeat myself I don't see much of a difference, and 
again I have to
second Ioannis for the reasons. And the thing that really made me do a 
-1 here
our Users don't see a reason to change either.
This is just a repetition of all what has been said/written before

Achim


Am 25.05.2012 19:10, schrieb Ioannis Canellos:
>> So having "feature:repo:list" sounds better to me than "feature:repo-list".
>>
> The thing is that its not *that* better to justify a change and all the
> effort that such a change requires (both from the broader community and
> from our existing user).
>
> Just to clarify. I do like the idea of nesting sub shells and the concept
> of separating them using the ":" as it might be useful for downstream
> projects or people building their custom distribution and have tens of
> commands under single scope. So I am +1 to that part.
>
> I am -1 on changing our existing commands, to adopt to such concept for the
> reasons already explained.
>


-- 
- Apache Karaf<http://karaf.apache.org/>  Committer&  PMC
- OPS4J Pax Web<http://wiki.ops4j.org/display/paxweb/Pax+Web/>    Committer&  Project
Lead
- Blog<http://notizblog.nierbeck.de/>


Mime
View raw message