karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Geer <ch...@cxtsoftware.com>
Subject Re: Add a scope feature-url
Date Fri, 25 May 2012 22:06:30 GMT
Maybe this isn't possible, but is there a way to make command text be
completely configurable? I know there are currently aliases, but that gets
real ugly real quick with multiple ways to do the same thing. It would be
nice to be able to define Command Sets that map command object to the term
that the shell will recognize which overwrites the default. It would be
even slicker if there were pre-defined sets that people could select
between like "legacy" and "new and fancy". That would give you the freedom
to restructure how the commands are actually implemented in code (sub
commands..) without impacting how the commands are called. So if the
default was "features:repo:add" but there was a way to make that
"features:addurl" by replacing the first one I think you could get
backwards compatibility and be able to refactor as needed.

Just a thought. It doesn't solve the "value" concern but it would fix the
backwards compatibility concern and allow people migrate to the new
commands at their own pace. I'm with Ioannis, I like the new proposed
structure in a lot of ways and dislike how some of the commands are now but
that is quickly outweighed by breaking compatibility.


On Fri, May 25, 2012 at 2:49 PM, Achim Nierbeck <bcanhome@googlemail.com>wrote:

> Christian,
> basically I just can repeat myself I don't see much of a difference, and
> again I have to
> second Ioannis for the reasons. And the thing that really made me do a -1
> here
> our Users don't see a reason to change either.
> This is just a repetition of all what has been said/written before
> Achim
> Am 25.05.2012 19:10, schrieb Ioannis Canellos:
>  So having "feature:repo:list" sounds better to me than
>>> "feature:repo-list".
>>>  The thing is that its not *that* better to justify a change and all the
>> effort that such a change requires (both from the broader community and
>> from our existing user).
>> Just to clarify. I do like the idea of nesting sub shells and the concept
>> of separating them using the ":" as it might be useful for downstream
>> projects or people building their custom distribution and have tens of
>> commands under single scope. So I am +1 to that part.
>> I am -1 on changing our existing commands, to adopt to such concept for
>> the
>> reasons already explained.
> --
> - Apache Karaf<http://karaf.apache.org/**>  Committer&  PMC
> - OPS4J Pax Web<http://wiki.ops4j.org/**display/paxweb/Pax+Web/<http://wiki.ops4j.org/display/paxweb/Pax+Web/>>
>    Committer&  Project Lead
> - Blog<http://notizblog.**nierbeck.de/ <http://notizblog.nierbeck.de/>>

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message