karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Pieber <anpie...@gmail.com>
Subject Re: ASM version....
Date Sat, 29 Sep 2012 04:15:17 GMT
well, good question; tbh now ideas what will happen if Aries will use
ASM 4 and e.g. Spring is going to install ASM 3 side by side. In
addition the question is: How much do we like to risk breaking
compatibility between minor releases. As I know my industrial
customers they would rather prefer stability over new features. In
other words, if you upgrade from 2.2.x to 2.3.x basically you want to
adapt nothing in your software; if you need the new features go with
3.0 and the hell of migrating...

Just my 0.02€

Kind regards,
Andreas

On Sat, Sep 29, 2012 at 6:06 AM, Freeman Fang <freeman.fang@gmail.com> wrote:
> Hi Dan,
>
> I think we should be OK to upgrade the asm version, karaf kit include the asm bundle
in startup.properties, AFAIK it's only used for the aries.proxy bundle, so if aries.proxy
need a higher version of asm, just upgrade asm in karaf should be safe.
>
> If other downstream projects which get deployed into karaf need use older asm version,
than they can use older asm bundle in their features.xml.
>
> @Team,
> please correct me if I'm wrong
>
> Freeman
> -------------
> Freeman Fang
>
> Red Hat, Inc.
> FuseSource is now part of Red Hat
> Web: http://fusesource.com | http://www.redhat.com/
> Twitter: freemanfang
> Blog: http://freemanfang.blogspot.com
> http://blog.sina.com.cn/u/1473905042
> weibo: http://weibo.com/u/1473905042
>
> On 2012-9-29, at 上午5:37, Daniel Kulp wrote:
>
>>
>> On Sep 28, 2012, at 5:06 PM, Andreas Pieber <anpieber@gmail.com> wrote:
>>
>>> The question is rather. Does asm 4.x break anything? Or is it only its
>>> internal handling?
>>
>> If I remember correctly, it pretty much breaks a lot of things.   It's mostly SOURCE
compatible, but not binary compatible at all.   Code compiled against 3.x won't work with
4.x and vice versa.   CXF switched to using some reflection magic to allow use of either version
of ASM.   Kind of crappy, but……..
>>
>> Dan
>>
>>
>>
>>>
>>> Kind regards Andreas
>>> On Sep 28, 2012 10:11 PM, "Daniel Kulp" <dkulp@apache.org> wrote:
>>>
>>>>
>>>> I was doing some testing with the latest Karaf 2.3.0 snapshot and
>>>> discovered that it only includes the 3.3.1 version of ASM.  However, the
>>>> Aries proxy stuff now requires 4.x.    Is that dependency  going to be
>>>> updated?   Should we have both to not break existing things?
>>>>
>>>>
>>>> --
>>>> Daniel Kulp
>>>> dkulp@apache.org - http://dankulp.com/blog
>>>> Talend Community Coder - http://coders.talend.com
>>>>
>>>>
>>
>> --
>> Daniel Kulp
>> dkulp@apache.org - http://dankulp.com/blog
>> Talend Community Coder - http://coders.talend.com
>>
>

Mime
View raw message