karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott England-Sullivan <sully6...@gmail.com>
Subject Re: [DISCUSSION] OSGi core version in Karaf version
Date Wed, 12 Sep 2012 13:30:13 GMT
Makes sense to me.  They still have a number of issues that they are
working to include in 1.8.x.  I will add a note in the Javadoc stating what
version is currently supported.

I am uploading a new patch to KARAF-1753 today.  It will take the place of
the one currently attached to the ticket.  It catches up on some conflicts
to the original patch.

Best Regards,
Scott ES

On Wed, Sep 12, 2012 at 8:24 AM, Jean-Baptiste Onofré <jb@nanthrax.net>wrote:

> Oh, got it Scott.
>
> IMHO, I would prefer to stay with Felix DS 1.6.0. As we are going to
> release 2.3.0 very soon, we can ship SNAPSHOT.
>
>
> Regards
> JB
>
> On 09/12/2012 03:22 PM, Scott England-Sullivan wrote:
>
>> Thanks for the response.  Bad question on my part.
>>
>> Better question is are we going to wait until all the functionality that
>> is
>> to be included in Karaf 2.3 that is dependent on the corresponding Felix
>> projects to get updated?  Felix DS (SCR) with support for OSGi 4.3/DS Spec
>> 1.2 (Felix DS 1.8.0-SNAPSHOT) is still under development.
>>
>> Should I migrate the SCR bundles to the Felix DS 1.8.0-SNAPSHOT for Karaf
>> 2.3?
>>
>> Or do I wait, leave it at OSGi 4.2/DS Spec 1.1 (Felix DS 1.6.0) and then
>> update them in a later release of Karaf 2.3.x?
>>
>> I am OK with either.  Just need your input.
>>
>> On Wed, Sep 12, 2012 at 7:55 AM, Jean-Baptiste Onofré <jb@nanthrax.net
>> >wrote:
>>
>>  Hi Scott,
>>>
>>> Karaf 2.3 already uses OSGi r4.3 (and corresponding framework).
>>>
>>> Regards
>>> JB
>>>
>>>
>>> On 09/12/2012 02:41 PM, Scott England-Sullivan wrote:
>>>
>>>  Hi All,
>>>>
>>>> What was the final outcome on this?  Is Karaf-2.3.x going to be based on
>>>> OSGi 4.3?
>>>>
>>>> Needing to know if I should update the Karaf 2.3.x SCR bundles to the
>>>> Felix
>>>> DS 1.8.0-SNAPSHOT which has the 4.3 support in it.
>>>>
>>>> Best Regards,
>>>> Scott ES
>>>>
>>>> On Sun, Aug 19, 2012 at 9:33 PM, Freeman Fang <freeman.fang@gmail.com
>>>>
>>>>> wrote:
>>>>>
>>>>
>>>>   +1 for Andreas's first plan.
>>>>
>>>>>
>>>>> Freeman
>>>>> -------------
>>>>> Freeman Fang
>>>>>
>>>>> FuseSource
>>>>> Email:ffang@fusesource.com
>>>>> Web: fusesource.com
>>>>> Twitter: freemanfang
>>>>> Blog: http://freemanfang.blogspot.****com<http://freemanfang.**
>>>>> blogspot.com <http://freemanfang.blogspot.com>>
>>>>> http://blog.sina.com.cn/u/****1473905042<http://blog.sina.com.cn/u/**1473905042>
>>>>> <http://blog.sina.**com.cn/u/1473905042<http://blog.sina.com.cn/u/1473905042>
>>>>> >
>>>>>
>>>>> weibo: http://weibo.com/u/1473905042
>>>>>
>>>>> On 2012-8-18, at 下午1:19, Andreas Pieber wrote:
>>>>>
>>>>>   TBH I personally would rather prefer:
>>>>>
>>>>>>
>>>>>> - Karaf 2.2.x => OSGi core 4.2.0
>>>>>> - Karaf 2.3.x => OSGi core 4.3.0
>>>>>> - Karaf 3.x.y => OSGi core 4.3.0
>>>>>> - Karaf 4.x.y => OSGi core 5.0.0
>>>>>>
>>>>>> or
>>>>>>
>>>>>> - Karaf 2.2.x => OSGi core 4.2.0
>>>>>> - Karaf 2.3.x => OSGi core 4.3.0
>>>>>> - Karaf 3.x.y => OSGi core 5.0.0
>>>>>>
>>>>>> I know that both options are not really optimal, but I don't think
>>>>>> that we really want to upgrade the inner core of the entire thing
to
>>>>>> the next major version in a minor of Karaf. There where some API
>>>>>> changes from a user lvl of view which disallow to drop the same bundle
>>>>>> into a 4.2/4.3 environment and a 5.0. I do not really fancy the idea
>>>>>> of breaking compatibility between minor releases. If ppls setup break
>>>>>> from one minor to the next they lost trust and upgrade ways too late
>>>>>> although there should be no reason.
>>>>>>
>>>>>> WDYT?
>>>>>>
>>>>>> Kind regards,
>>>>>> Andreas
>>>>>>
>>>>>> On Sat, Aug 18, 2012 at 12:47 AM, Jean-Baptiste Onofré <
>>>>>> jb@nanthrax.net
>>>>>>
>>>>>>>
>>>>>>>
>>>>>>  wrote:
>>>>>
>>>>>  Hi team,
>>>>>>
>>>>>>>
>>>>>>> As you know, OSGi core 5.0.0 has been released.
>>>>>>>
>>>>>>> I would like to discuss about which version of Karaf should support
>>>>>>>
>>>>>>>  which
>>>>>>
>>>>>
>>>>>  version of the OSGi core (and so the corresponding OSGi frameworks).
>>>>>>
>>>>>>>
>>>>>>> I have the following proposal:
>>>>>>>
>>>>>>> - Karaf 2.2.x => OSGi core 4.2.0
>>>>>>> - Karaf 2.3.x => OSGi core 4.3.0
>>>>>>> - Karaf 3.0.x => OSGi core 4.3.0
>>>>>>> - Karaf 3.1.x => OSGi core 5.0.0
>>>>>>>
>>>>>>> I would wait Karaf 3.1.x to update to OSGi core 5.0.0 as the
OSGi
>>>>>>>
>>>>>>>  frameworks
>>>>>>
>>>>>
>>>>>  are not yet fully ready on this specification.
>>>>>>
>>>>>>>
>>>>>>> WDYT ?
>>>>>>>
>>>>>>> Regards
>>>>>>> JB
>>>>>>> --
>>>>>>> Jean-Baptiste Onofré
>>>>>>> jbonofre@apache.org
>>>>>>> http://blog.nanthrax.net
>>>>>>> Talend - http://www.talend.com
>>>>>>>
>>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>  --
>>> Jean-Baptiste Onofré
>>> jbonofre@apache.org
>>> http://blog.nanthrax.net
>>> Talend - http://www.talend.com
>>>
>>>
>>
>>
>>
> --
> Jean-Baptiste Onofré
> jbonofre@apache.org
> http://blog.nanthrax.net
> Talend - http://www.talend.com
>



-- 
-- 
Scott England-Sullivan
----------------------------------
FuseSource
Web:     http://www.fusesource.com
Blog:     http://sully6768.blogspot.com
Twitter: sully6768

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message