karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Pieber <anpie...@gmail.com>
Subject Re: Karaf 2.3.x and Karaf 3.0.x support ASM in Version 4.1, why?
Date Tue, 22 Jan 2013 07:52:05 GMT
cheater :P but as long as it works... well better than nothing.

kind regards,
Andreas

On Tue, Jan 22, 2013 at 8:50 AM, Achim Nierbeck <bcanhome@googlemail.com> wrote:
> oops ....
>
> though some good news for the ASM stuff, I was able to create a workaround
> for Pax-Web. A fragment Bundle attached to xbean binds the version to [3.1,
> 4.0). Now Pax-Web 3.0.0.M2 will be usable with Karaf 3.0 again :-)
>
> regards, Achim
>
>
> 2013/1/22 Andreas Pieber <anpieber@gmail.com>
>
>> Outsch, I just set the release date of Karaf 3 in my private Calendar
>> to 2014... :-)
>>
>> Kind regards,
>> Andreas
>>
>> On Mon, Jan 21, 2013 at 6:11 PM, Achim Nierbeck <bcanhome@googlemail.com>
>> wrote:
>> > looks like this issue at xbean is going to block aries and pax-web
>> > https://issues.apache.org/jira/browse/XBEAN-230
>> >
>> > regards, Achim
>> >
>> >
>> > 2013/1/21 Achim Nierbeck <bcanhome@googlemail.com>
>> >
>> >> hmm, interesting.
>> >> Aries Annotations won't work with this either ...
>> >>
>> >> regards, Achim
>> >>
>> >>
>> >> 2013/1/21 jb@nanthrax.net <jb@nanthrax.net>
>> >>
>> >> It was a requirement for Aries Proxy update.
>> >>>
>> >>> Regards
>> >>> JB
>> >>>
>> >>> --
>> >>> Jean-Baptiste Onofré
>> >>> jbonofre@apache.org
>> >>> http://blog.nanthrax.net
>> >>> Talend - http://wwx.talend.com
>> >>>
>> >>> ----- Reply message -----
>> >>> From: "Achim Nierbeck" <bcanhome@googlemail.com>
>> >>> To: <dev@karaf.apache.org>
>> >>> Subject: Karaf 2.3.x and Karaf 3.0.x support ASM in Version 4.1, why?
>> >>> Date: Mon, Jan 21, 2013 6:12 am
>> >>>
>> >>>
>> >>> Hi guys,
>> >>>
>> >>> anyone know why we moved to version 4.1 of ASM in Karaf 2.3 and 3.0?
>> >>> Cause this is an issue for Pax-Web right now (at least if working with
>> >>> xbean-finder) and surely will also be an issue for Aries Annotation
>> >>> support.
>> >>> To my knowledge the Aries Annotation scanner also uses xbean-finder
in
>> >>> version 3.x which needs ASM 3.1 and not 4.x.
>> >>> If needed we gonna need to raise an issue at the xbean project to
>> tighten
>> >>> the range for ASM to [3.1, 4.0)
>> >>>
>> >>>
>> >>> regards, Achim
>> >>>
>> >>> --
>> >>>
>> >>> Apache Karaf <http://karaf.apache.org/> Committer & PMC
>> >>> OPS4J Pax Web <http://wiki.ops4j.org/display/paxweb/Pax+Web/>
>> Committer &
>> >>> Project Lead
>> >>> OPS4J Pax for Vaadin <
>> http://team.ops4j.org/wiki/display/PAXVAADIN/Home>
>> >>> Commiter & Project Lead
>> >>> blog <http://notizblog.nierbeck.de/>
>> >>>
>> >>
>> >>
>> >>
>> >> --
>> >>
>> >> Apache Karaf <http://karaf.apache.org/> Committer & PMC
>> >> OPS4J Pax Web <http://wiki.ops4j.org/display/paxweb/Pax+Web/>
>> Committer &
>> >> Project Lead
>> >> OPS4J Pax for Vaadin <http://team.ops4j.org/wiki/display/PAXVAADIN/Home
>> >
>> >> Commiter & Project Lead
>> >> blog <http://notizblog.nierbeck.de/>
>> >>
>> >
>> >
>> >
>> > --
>> >
>> > Apache Karaf <http://karaf.apache.org/> Committer & PMC
>> > OPS4J Pax Web <http://wiki.ops4j.org/display/paxweb/Pax+Web/> Committer
>> &
>> > Project Lead
>> > OPS4J Pax for Vaadin <http://team.ops4j.org/wiki/display/PAXVAADIN/Home>
>> > Commiter & Project Lead
>> > blog <http://notizblog.nierbeck.de/>
>>
>
>
>
> --
>
> Apache Karaf <http://karaf.apache.org/> Committer & PMC
> OPS4J Pax Web <http://wiki.ops4j.org/display/paxweb/Pax+Web/> Committer &
> Project Lead
> OPS4J Pax for Vaadin <http://team.ops4j.org/wiki/display/PAXVAADIN/Home>
> Commiter & Project Lead
> blog <http://notizblog.nierbeck.de/>

Mime
View raw message