karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: Spring ... not longer OSGIfied
Date Sun, 02 Jun 2013 22:54:43 GMT
One thing that projects like CXF and Camel and such SHOULD be aware of is that since the jars
they are building against are no longer bundles, the bundle plugin will not create version
ranges for the imports.   They likely should re-audit any jars they have that use spring to
check to make sure the proper version ranges are in place.

Dan


On May 31, 2013, at 4:44 PM, Jean-Baptiste Onofré <jb@nanthrax.net> wrote:

> It's on the Spring EBR:
> 
> http://ebr.springsource.com/repository/app/faq
> 
> FYI, Karaf 2.x and 3.x now uses Spring 3.2.x as OSGi bundle, and etc/org.ops4j.pax.url.mvn.cfg
contains the Spring EBR repository.
> 
> Regards
> JB
> 
> On 05/31/2013 07:18 PM, Charles Moulliard wrote:
>> Hi,
>> 
>> As last bundles of Spring (> 3.2) are not longer OSGIfied, what do we plan
>> to do :
>> 
>> karaf@root> install mvn:org.springframework/spring-orm/3.2.2.RELEASE
>> Bundle ID: 638
>> karaf@root> headers 638
>> 
>> Bundle 638
>> ----------
>> Manifest-Version = 1.0
>> Implementation-Version = 3.2.2.RELEASE
>> Implementation-Title = spring-orm
>> Created-By = 1.7.0_10 (Oracle Corporation)
>> 
>> 1) Create ServiceMix Spring OSGI Bundle
>> 2) Switch from Spring to Blueprint, Aries JTA, Aries JPA, ...
>> 
>> Regards,
>> 
> 
> -- 
> Jean-Baptiste Onofré
> jbonofre@apache.org
> http://blog.nanthrax.net
> Talend - http://www.talend.com

-- 
Daniel Kulp
dkulp@apache.org - http://dankulp.com/blog
Talend Community Coder - http://coders.talend.com


Mime
View raw message