karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Spring OSGi bundles no longer being released
Date Mon, 20 Jan 2014 17:30:10 GMT
Good point Christian.

As Spring won't really support "publicly (via EBR)" OSGi bundles, we may 
have issue in Spring running on OSGi.

When using our own bundles, we can add a note to warn the users.

Regards
JB

On 01/20/2014 06:24 PM, Christian Schneider wrote:
> Somehow I wonder how well future spring versions will behave in OSGi.
> I think we should start to at least warn our users that continued use of
> spring in OSGi is an increasing risk.
>
> Christian
>
> Am 20.01.2014 16:33, schrieb Claus Ibsen:
>> Hi
>>
>> So I have been waiting for Spring to release Spring 3.2.5 or newer as
>> OSGi bundle on their EBR repo at
>> http://ebr.springsource.com/repository/
>>
>> The last release available is 3.2.4.
>>
>> I asked on twitter and got this reply
>> https://twitter.com/glynnormington/status/425280920888016896
>>
>> Also if you see the FAQ here, it says the repo is frozen
>> http://ebr.springsource.com/repository/app/faq
>>
>> And that it may not be online anymore after September 2014.
>>
>> Glyn, refers to Eclipse EBR but it looks like they have not taken over
>> doing Spring OSGi release
>> http://www.eclipse.org/ebr/
>>
>>
>> So down the road we have 2 problems
>>
>> 1)
>> Spring 3.2.4 is the last OSGi bundle release
>>
>> 2)
>> The Spring EBR repo will be taken offline in the future
>>
>>
>>
>> So any thoughts what we can do?
>>
>>
>
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message