karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Giuseppe Gerla <giuseppe.ge...@gmail.com>
Subject Re: [INFO] Change in EIK version
Date Tue, 25 Feb 2014 15:43:30 GMT
Yes, it is configured.But doesn't work



2014-02-25 14:39 GMT+01:00 Filippo Balicchia <fbalicchia@gmail.com>:

> Hi Giuseppe,
> Did you configure osgi Frameworks  ?
> try to set on "Apache Karaf on equinox."
>
> Regards
>
> --Filippo
>
>
>
>
>
>
> 2014-02-25 10:34 GMT+01:00 Giuseppe Gerla <giuseppe.gerla@gmail.com>:
>
> > Hi
> > I have installed princexml tool, update to the last version of branch and
> > successifully build all module of Eik-2.3.1
> > After I have installed in Eclipse Kepler from
> > \eik-2.3.1\features\org.apache.karaf.eik.repository\target\repository
> > folder.
> > I have also created a new Apache Karaf Poject and configured the target
> > platform.
> > When I start the debug, I have this error:
> >
> > !SESSION 2014-02-25 10:33:02.249
> > -----------------------------------------------
> > eclipse.buildId=unknown
> > java.version=1.7.0_45
> > java.vendor=Oracle Corporation
> > BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=it_IT
> > Command-line arguments:  -dev
> > file:D:/LaunchFolder/configuration/dev.properties
> >
> > !ENTRY org.eclipse.osgi 4 0 2014-02-25 10:33:06.943
> > !MESSAGE Application error
> > !STACK 1
> > java.lang.RuntimeException: No application id has been found.
> > at
> >
> >
> org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
> > at
> >
> >
> org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
> > at
> >
> >
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
> > at
> >
> >
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
> > at
> >
> >
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
> > at
> >
> >
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
> > at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> > at
> >
> >
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
> > at
> >
> >
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
> > at java.lang.reflect.Method.invoke(Method.java:606)
> > at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)
> > at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)
> > at org.eclipse.equinox.launcher.Main.run(Main.java:1450)
> > at org.eclipse.equinox.launcher.Main.main(Main.java:1426)
> >
> >
> > Can you help me?
> >
> >
> > Regards
> > Giuseppe
> >
> >
> > 2014-02-24 14:18 GMT+01:00 Filippo Balicchia <fbalicchia@gmail.com>:
> >
> > > Hi Giuseppe,
> > >
> > > thanks for log, your problem is already address in jira
> > > https://issues.apache.org/jira/browse/KARAF-2782
> > >
> > > Regards
> > >
> > > --Filippo
> > >
> > >
> > >
> > >
> > > 2014-02-24 12:12 GMT+01:00 Giuseppe Gerla <giuseppe.gerla@gmail.com>:
> > >
> > > > Hi Filippo
> > > > I sended you a private email with attached file.
> > > >
> > > > I hope that it can help you to find the problem.
> > > >
> > > > If you need some other help, I'm available.
> > > >
> > > > Regards
> > > > Giuseppe
> > > >
> > > >
> > > > 2014-02-24 11:33 GMT+01:00 Filippo Balicchia <fbalicchia@gmail.com>:
> > > >
> > > > > Hi Giuseppe,
> > > > > the error obtained compiling manual on my Linux Box is different
> from
> > > > > yours.
> > > > >
> > > > > Could you please type this command  and send me the output
> > > > > mvn install -X -pl manual > manulproblem.txt
> > > > >
> > > > > thanks for help
> > > > >
> > > > > --Filippo
> > > > >
> > > > >
> > > > > 2014-02-21 18:45 GMT+01:00 Jean-Baptiste Onofré <jb@nanthrax.net>:
> > > > >
> > > > > > Hi,
> > > > > >
> > > > > > I gonna fix the repository to see if it's related.
> > > > > >
> > > > > > I keep you posted as soon as a new SNAPSHOT is deployed.
> > > > > >
> > > > > > Regards
> > > > > > JB
> > > > > >
> > > > > >
> > > > > > On 02/21/2014 06:37 PM, siwatson wrote:
> > > > > >
> > > > > >> Firstly, a big thanks for updating EIK. I tried the 3.0.0
> snapshot
> > > > with
> > > > > >> Eclipse Kepler SR1 and Karaf 3.0.0. Installation went smoothly
> and
> > > I'm
> > > > > >> able
> > > > > >> to create a Karaf Install project. When I try to create
a new
> OSGi
> > > run
> > > > > >> configuration (based on the EIK user guide), I get an error
in
> > > > Eclipse.
> > > > > >> Not
> > > > > >> sure if it's something I'm doing wrong or a bug?
> > > > > >>
> > > > > >>
> > > > > >>
> > > > > >>
> > > > > >>
> > > > > >>
> > > > > >> --
> > > > > >> View this message in context: http://karaf.922171.n3.nabble.
> > > > > >> com/INFO-Change-in-EIK-version-tp4031799p4031877.html
> > > > > >> Sent from the Karaf - Dev mailing list archive at Nabble.com.
> > > > > >>
> > > > > >>
> > > > > > --
> > > > > > Jean-Baptiste Onofré
> > > > > > jbonofre@apache.org
> > > > > > http://blog.nanthrax.net
> > > > > > Talend - http://www.talend.com
> > > > > >
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message