karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: JPA with Karaf 4.0.1
Date Wed, 02 Sep 2015 12:16:09 GMT
Hi Damien,

It seems that you have the same bug already reported in Aries JPA 
Blueprint 2.1: there's a typo mistake in the namespace:

http://aries.apache.org/xmlns/jpan/v1.1.0

instead of

http://aries.apache.org/xmlns/jpa/v1.1.0

Displaying the services of the JPA bundle (using bundle:service) will 
show you the namespace.

Can you check that ?

I plan to fix that and to do a quick Aries JPA release in order to fix that.

Regards
JB

On 09/02/2015 01:42 PM, Damien wrote:
> Hello !
>
> I try to migrate from Karaf 3.0.2 to 4.0.1. I manually install feature
> aries-blueprint and everything seem to work except one bundle. Here is the
> error:
>
>
> Bundle core.jpa.impl is waiting for namespace handlers
> [http://aries.apache.org/xmlns/jpa/v1.1.0].
>
> Blueprint.xml begins with:
> <blueprint default-activation="eager"
>             xmlns="http://www.osgi.org/xmlns/blueprint/v1.0.0"
>             xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>             xmlns:tx="http://aries.apache.org/xmlns/transactions/v1.0.0"
>             xmlns:jpa="http://aries.apache.org/xmlns/jpa/v1.1.0">
>
> and here is my feature:list -iName            | Version        | Required |
> State   | Repository             | Description
> ----------------------------------------------------------------------------------------------------------------------------------
> aries-proxy     | 4.0.1          |          | Started | standard-4.0.1
> | Aries Proxy
> aries-blueprint | 4.0.1          | x        | Started | standard-4.0.1
> | Aries Blueprint
> feature         | 4.0.1          | x        | Started | standard-4.0.1
> | Features Support
> shell           | 4.0.1          | x        | Started | standard-4.0.1
> | Karaf Shell
> shell-compat    | 4.0.1          | x        | Started | standard-4.0.1
> | Karaf Shell Compatibility
> deployer        | 4.0.1          | x        | Started | standard-4.0.1
> | Karaf Deployer
> bundle          | 4.0.1          | x        | Started | standard-4.0.1
> | Provide Bundle support
> config          | 4.0.1          | x        | Started | standard-4.0.1
> | Provide OSGi ConfigAdmin support
> diagnostic      | 4.0.1          | x        | Started | standard-4.0.1
> | Provide Diagnostic support
> instance        | 4.0.1          | x        | Started | standard-4.0.1
> | Provide Instance support
> jaas            | 4.0.1          | x        | Started | standard-4.0.1
> | Provide JAAS support
> log             | 4.0.1          | x        | Started | standard-4.0.1
> | Provide Log support
> package         | 4.0.1          | x        | Started | standard-4.0.1
> | Package commands and mbeans
> service         | 4.0.1          | x        | Started | standard-4.0.1
> | Provide Service support
> system          | 4.0.1          | x        | Started | standard-4.0.1
> | Provide System support
> kar             | 4.0.1          | x        | Started | standard-4.0.1
> | Provide KAR (KARaf archive) support
> management      | 4.0.1          | x        | Started | standard-4.0.1
> | Provide a JMX MBeanServer and a set of MBeans in
> wrap            | 0.0.0          | x        | Started | standard-4.0.1
> | Wrap URL handler
> mongoose.core   | 0.0.1.SNAPSHOT | x        | Started |
> feature-0.0.1-SNAPSHOT | feature
> transaction-api | 1.1.0          |          | Started | enterprise-4.0.1
> |
> persistence-api | 2.0.0          |          | Started | enterprise-4.0.1
> | Persistence API
> persistence-api | 2.1.0          |          | Started | enterprise-4.0.1
> | Persistence API
> jpa             | 2.1.0          |          | Started | enterprise-4.0.1
> | OSGi Persistence Container
> openjpa         | 2.4.0          |          | Started | enterprise-4.0.1
> | Apache OpenJPA 2.4.x persistence engine support
> jndi            | 4.0.1          |          | Started | enterprise-4.0.1
> | OSGi Service Registry JNDI access
> jdbc            | 4.0.1          |          | Started | enterprise-4.0.1
> | JDBC service and commands
>
> (mongoose.core is the feature i try to install)
>
> Do I use a wrong namespace ? Do I forget to install a feature ?
>
> Thanks
>
>
>
>
>
>
> --
> View this message in context: http://karaf.922171.n3.nabble.com/JPA-with-Karaf-4-0-1-tp4042279.html
> Sent from the Karaf - Dev mailing list archive at Nabble.com.
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message