karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Schneider <ch...@die-schneider.net>
Subject Re: [VOTE] Apache Karaf 4.0.2 release
Date Sun, 11 Oct 2015 17:24:35 GMT
I just did some more testing and found a problem.

When I run my tasklist-blueprint-cdi example it works fine at the start 
but after some time I see this exception:
2015-10-11 19:08:43,371 | ERROR | rint Extender: 2 | 
BlueprintContainerImpl           | 12 - org.apache.aries.blueprint.core 
- 1.4.4 | Unable to start blueprint container for bundle 
net.lr.tasklist.cdi.tasklist-persistence/1.0.0.SNAPSHOT due to 
unresolved dependencies []
java.util.concurrent.TimeoutException
     at 
org.apache.aries.blueprint.container.BlueprintContainerImpl$1.run(BlueprintContainerImpl.java:336)[12:org.apache.aries.blueprint.core:1.4.4]
     at 
org.apache.aries.blueprint.utils.threading.impl.DiscardableRunnable.run(DiscardableRunnable.java:48)[12:org.apache.aries.blueprint.core:1.4.4]
     at 
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)[:1.8.0_60]
     at java.util.concurrent.FutureTask.run(FutureTask.java:266)[:1.8.0_60]
     at 
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)[:1.8.0_60]
     at 
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)[:1.8.0_60]
     at 
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_60]
     at 
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_60]
     at java.lang.Thread.run(Thread.java:745)[:1.8.0_60]

After this the tasklist-persistence bundle does not work anymore. If 
this does not only happen with my example then it would be a pretty 
critical bug.

I am not yet sure what the reason is but I will dig some more. I think 
the problem could be either in blueprint core or in blueprint jpa.

If you want to test yourself you should use the branch jpa-2.1.0 (old 
name ... it uses jpa 2.2.0 now).
https://github.com/cschneider/Karaf-Tutorial/tree/master/tasklist-blueprint-cdi


Christian


On 11.10.2015 16:53, Christian Schneider wrote:
> +1 (non binding)
>
> Tested my blueprint and  DS examples (jpa,transaction, hibernate, cxf, 
> jaxrs-connector)
>
> Looks all good.
>
> Christian

-- 
Christian Schneider
http://www.liquid-reality.de

Open Source Architect
http://www.talend.com


Mime
View raw message