karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chandan <chandan.mysorebalakris...@in.bosch.com>
Subject Cellar Clustering in karaf is not working properly
Date Wed, 17 Aug 2016 11:50:11 GMT
Hello,

I followed the steps mentioned here 

https://karaf.apache.org/manual/cellar/latest-4/#_enable_http_balancer

In both the machines i installed cellar and did the tcp/ip configuration by
adding IP of both machines. 
they got interconnected. 

In first machine, 
karaf@node1()> feature:install http 
karaf@node1()> feature:install http-whiteboard 
karaf@node1()> feature:repo-add cellar 4.0.0 
karaf@node1()> feature:install cellar 
karaf@node1()> cluster:feature-install default cellar-http-balancer 
karaf@node1()> feature:install webconsole 
 karaf@node1()>http:list 
karaf@node1()> cluster:http-list default 

In second machine 

karaf@node2()> feature:install http 
karaf@node2()> feature:install http-whiteboard 
karaf@node2()> feature:repo-add cellar 4.0.0 
karaf@node2()> feature:install cellar 
karaf@node2()> cluster:http-list default 
karaf@node2()> http:list

105 | KarafOsgiManager           | ServletModel-2  | Undeployed  |
/system/console     | [/system/console/*]
107 | InstancePlugin             | ServletModel-7  | Deployed    | /instance          
| [/instance/*]
105 | ResourceServlet            | /res            | Deployed    |
/system/console/res | [/system/console/res/*]
104 | GogoPlugin                 | ServletModel-4  | Deployed    | /gogo              
| [/gogo/*]
102 | FeaturesPlugin             | ServletModel-12 | Deployed    | /features          
| [/features/*]
105 | KarafOsgiManager           | ServletModel-9  | Deployed    |
/system/console     | [/system/console/*]
106 | CellarBalancerProxyServlet | ServletModel-14 | Failed      |
/system/console/res | [/system/console/res/*]
106 | CellarBalancerProxyServlet | ServletModel-15 | Failed      |
/system/console     | [/system/console/*]
106 | CellarBalancerProxyServlet | ServletModel-16 | Deployed    | /cxf               
| [/cxf/*]

I stop sync both the clustering.

In first machine, i added cxf features and deployed one web service bundle.
As per the documentation,

if i hit the browser with below url
localhost:8181/system/console, it should open up first machine web console
from second machine

But for me it is opening second machine web console itself.



--
View this message in context: http://karaf.922171.n3.nabble.com/Cellar-Clustering-in-karaf-is-not-working-properly-tp4047567.html
Sent from the Karaf - Dev mailing list archive at Nabble.com.

Mime
View raw message