karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Sicker <boa...@gmail.com>
Subject Log4j 1.x will not work in Java 9, need to migrate to 2.x
Date Wed, 10 Aug 2016 13:51:24 GMT
Hello guys, I noticed in Karaf 4.0.5, Log4j 1.x is still being used as the
logging framework. This is no longer supported in Java 9 due to being end
of life and a bug involving the JDK version number string having changed
format significantly.

Are there plans to make Log4j 2.x the default in Karaf 4.1 or 5.0? If not,
I can help you guys migrate. We're keeping track of migration efforts in
this issue: https://issues.apache.org/jira/browse/LOG4J2-1473

-- 
Matt Sicker <boards@gmail.com>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message