karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Nodet <gno...@apache.org>
Subject Re: Java 9 work
Date Wed, 04 Oct 2017 07:57:42 GMT
I think we should aim for Karaf 4.3 which would include:
  * Jetty 9.4
  * Pax-Web 6.1
  * Asm 6
  * Xbean 4.6
  * aries proxy, spifly supporting asm 6
  * updated servicemix-specs for Java 9, see KARAF-3518
  * testing...

2017-10-03 17:06 GMT+02:00 Guillaume Nodet <gnodet@apache.org>:

>
>
> 2017-10-03 16:23 GMT+02:00 Fabian Lange <fabian.lange@codecentric.de>:
>
>> Hi Guys,
>> whats our plan to support Java 9?
>>
>> Will that be karaf 4.2
>> 5.0
>> or even 4.1/4.0 backports?
>>
>
> I'd say 4.3
>
>
>>
>> The only real task is writing proper module-info files which should be
>> easy
>> for anything osgi.
>> I would like to look into this.
>>
>
> Those are definitely not needed afaik. What do you have in mind ?
>
> What is needed is:
>   * need a GA version of asm 6
>   * support from downstream projects like xbean, jetty, undertow, pax-web,
> aries-proxy, etc...
>   * KARAF-3518 which I think requires a fair amount of work on
> servicemix-specs and provide jigsaw modules for some implementations such
> as xerces, xalan...
>   * If you run master with java9, you should see a warning when the
> console is started.  That would require some work in gogo/jline.
>
>
>>
>>
>> Fabian
>>
>
>
>
> --
> ------------------------
> Guillaume Nodet
>
>


-- 
------------------------
Guillaume Nodet

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message