karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Cosentino <ancosen1...@yahoo.com.INVALID>
Subject Re: [PROPOSAL] Apache Karaf Decanter 2.0.0
Date Mon, 08 Jan 2018 13:31:07 GMT
+1.

Thanks JB.

--
Andrea Cosentino 
----------------------------------
Apache Camel PMC Member
Apache Karaf Committer
Apache Servicemix PMC Member
Email: ancosen1985@yahoo.com
Twitter: @oscerd2
Github: oscerd






On Monday, January 8, 2018, 2:25:34 PM GMT+1, Jean-Baptiste Onofré <jb@nanthrax.net>
wrote: 





Hi,

I'm working on the preparation of the next Decanter release.

I would like to bump Decanter version to 2.0.0 for the following reasons:

1. Upgrade to OSGi Spec 6.0.0, especially for Compendium & DS. It means that 
Decanter 2.0.0 will require Karaf >= 3.0.0.
2. Up to now, Decanter provided embedded feature for Elasticsearch, Kibana, 
OrientDB. Those features will still be present in Decanter and they won't be the 
recommended approach. We encourage users to use external instances for 
production. For instance, Kibana 6 is not easy to ship in Karaf (due to 
node.js), and I think it's more reliable to use a "native" Kibana instance.
3. We will introduce new webconsole and shell commands for Decanter. It will be 
base on Karaf 4 style.

Thoughts ?

Regards
JB
-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message