karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grzegorz Grzybek <gr.grzy...@gmail.com>
Subject Re: compilation failing with karaf 4.2.0.M2
Date Thu, 08 Mar 2018 13:32:00 GMT
Which Maven version do you use?

regards
Grzegorz Grzybek

2018-03-08 14:31 GMT+01:00 shivibansal <shivanibansal1985@gmail.com>:

> Hi All,
>
> we were trying to upgrade KARAF version of our project to 4.2.0M2. rest of
> the modules compiled fine but with build folder which generates the KAR
> files, it fails while compilation with below error.
>
> [ERROR] Failed to execute goal
> org.apache.karaf.tooling:karaf-maven-plugin:4.2.0
> .M2:verify (default-verify) on project gems-wrapper: Execution
> default-verify of
>  goal org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2:verify failed:
> Unable
>  to load the mojo 'verify' (or one of its required components) from the
> plugin '
> org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2':
> com.google.inject.Provisi
> onException: Guice provision errors:
> [ERROR]
> [ERROR] 1) No implementation for
> org.eclipse.aether.repository.WorkspaceReader w
> as bound.
> [ERROR] while locating org.apache.karaf.tooling.VerifyMojo
> [ERROR] at
> ClassRealm[plugin>org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M
> 2, parent: sun.misc.Launcher$AppClassLoader@5c647e05]
> [ERROR] while locating org.apache.maven.plugin.Mojo annotated with
> @com.google.i
> nject.name.Named(value=org.apache.karaf.tooling:karaf-
> maven-plugin:4.2.0.M2:veri
> fy)
> [ERROR]
> [ERROR] 1 error
> [ERROR] role: org.apache.maven.plugin.Mojo
> [ERROR] roleHint:
> org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2:verify
> [ERROR] -> [Help 1]
> [ERROR]
>
> Can you please suggest?
>
> Regards
> Shivani
>
>
>
> --
> Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message