karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: issues while using Spring 5.0.4 with latest KARAF 4.2.0
Date Wed, 18 Jul 2018 12:49:39 GMT
Hi Munish,

spring-osgi (spring-dm) doesn't support Spring 5.

So, if you want to use spring-dm, you are stuck with Spring 4: no other
way. In Karaf 4.2.0 vanilla distribution, it works because we provide
several spring versions, and when you install spring-dm  feature, it
installs spring 4.0.x.

I recommend you to update to blueprint (replacement of spring-dm).

Regards
JB

On 18/07/2018 14:37, munishgupta.asr wrote:
> Hi All,
> 
> We are using KARAF 4.0.0 for now and trying to upgrade it to 4.2.0 now. We
> are also upgrading jetty libraries to latest supported version and upgraded
> spring version to 5.0.4 Release.
> 
> for using Spring on OSGI, currently we were using 'spring-osgi-web' and
> 'spring-osgi-core' libraries of 'org.springframework.osgi;  with version as
> 1.2.1. 
> 
> After upgrade, it seems these libraries are only supported upto Spring
> Version 4.0.0 and not further.
> 
> Can you please guide me what i should be trying for using Spring 5.0.4 on
> latest KARAF 4.2.0?
> 
> Regards
> Munish 
> 
> 
> 
> --
> Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html
> 

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message