karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rob64 <robtheria...@gmail.com>
Subject Karaf 4.2.x Cellar HTTP load balancing
Date Tue, 04 Dec 2018 22:09:06 GMT
Hi,

It seems there is not a version of cellar http load balancer that works with
karaf "container" 4.2.x ?

When I try to use the latest of both I get the following pax web version
mismatch.


Any plans/ETA on updating cellar http load balancer to use pax web 7x?


Thanks.


Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to
resolve org.apache.karaf.cellar.http.balancer/4.1.2: missing requirement
[org.apache.karaf.cellar.http.balancer/4.1.2] osgi.wiring.package;
filter:="(&(osgi.wiring.package=org.ops4j.pax.web.service.spi)(version>=4.0.0)(!(version>=7.0.0)))"
        at
org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
        ... 13 more
Error executing command: Unable to resolve root: missing requirement [root]
osgi.identity; osgi.identity=cellar-http-balancer; type=karaf.feature;
version="[4.1.2,4.1.2]";
filter:="(&(osgi.identity=cellar-http-balancer)(type=karaf.feature)(version>=4.1.2)(version<=4.1.2))"
[caused by: Unable to resolve cellar-http-balancer/4.1.2: missing
requirement [cellar-http-balancer/4.1.2] osgi.identity;
osgi.identity=org.apache.karaf.cellar.http.balancer; type=osgi.bundle;
version="[4.1.2,4.1.2]"; resolution:=mandatory [caused by: Unable to resolve
org.apache.karaf.cellar.http.balancer/4.1.2: missing requirement
[org.apache.karaf.cellar.http.balancer/4.1.2] osgi.wiring.package;
filter:="(&(osgi.wiring.package=org.ops4j.pax.web.service.spi)(version>=4.0.0)(!(version>=7.0.0)))"]]



--
Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html

Mime
View raw message