karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Help to get out of pax-web from karaf distribution
Date Wed, 05 Dec 2018 12:18:41 GMT
Hi,

We can do a cleanup for Karaf 4.3.0.

However, there's reason why we have features in standard Karaf 
distribution. For instance, the "official" Hibernates features repo was 
not fully correct, that's why we override in Karaf.

As said in another e-mail, my proposal would be:

1. Reduce the minimal distribution to be even more light without a lot 
of features repos references
2. Cleanup the standard features repos to better leverage repos provided 
by third parties, assuming they are good enough.

Regards
JB

On 05/12/2018 12:30, Grzegorz Grzybek wrote:
> Hello
> 
> +1 That for example happened to Hibernate which (at some point) started to
> provide own features. Same for JPA.
> PAX-WEB (and other PAX projects) provide own Karaf features and it's worth
> considering to remove the inclusion of pax-web features from karaf
> enterprise features.
> 
> There's no need to change terminology, simply we should avoid including
> other repos from "native" / "built in" repos.
> 
> Maybe it's worth considering in Karaf 4.3.0 (Karaf 5.0.0?).
> 
> regards
> Grzegorz Grzybek
> 
> śr., 5 gru 2018 o 12:21 Christian Schneider <chris@die-schneider.net>
> napisał(a):
> 
>> I think this points to an interesting problem in current karaf.
>> Karaf comes with some feature repos installed and even with some features
>> installed.
>> This is very good for learning karaf but it is not good when you build and
>> maintain your application.
>>
>> Things that we currently make hard to do:
>> - You have an application that is based on karaf features as well as other
>> features. It is quite hard to update your application to a new karaf as it
>> brings a lot of feature updates that you might not want.
>> - Switch some implementations. For Sai wanted to not install pax web. In my
>> recent case I wanted to update blueprint core.
>>
>> I think many of these problems come from the way karaf features are
>> offered:
>> - Many features are versioned together with karaf. So when you update karaf
>> you get new versions of the features / bundles even if you do not want
>> them.
>> - Some karaf features combine too many unrelated things. E.g the enterprise
>> feature repo combines jpa, jms, peristence providers. Sometimes even
>> different versions of these.
>>
>> I think we can fix a lot of this by moving as many features as possible to
>> the projects where the bundles come from. E.g Aries jpa already provides a
>> features. This allows to use any karaf version and install any jpa version
>> on it. Unfortunately this does not work in practice as the feature needs
>> transactions as well as blueprint that are part of karaf itself.
>>
>> So I think we should move more features out of karaf and into the
>> individual projects.
>> Of course we must give these repos nice aliases so they are still easy to
>> install.
>>
>> WDYT?
>>
>> Christian
>>
>>
>> Am Mi., 5. Dez. 2018 um 11:41 Uhr schrieb Sai Sankar <
>> saisankar.c@motivitylabs.com>:
>>
>>> Hi All
>>>
>>> I dont want Pax-web features to be installed or installable with KARAF
>>> 4.2.0. Tried Standard and minimal distributions too, but either way it is
>>> installing pax-web features.
>>>
>>> Karaf Version is  : 4.2
>>>
>>> pax-web-core                    | 7.0.0            |          | Started
>>> | org.ops4j.pax.web-7.0.0           | Provide Core pax-web bundles
>>> pax-jetty                       | 9.4.6.v20170531  |          | Started
>>> | org.ops4j.pax.web-7.0.0           | Provide Jetty engine support
>>> pax-jetty-http2                 | 7.0.0            |          |
>> Uninstalled
>>> | org.ops4j.pax.web-7.0.0           | Optional additional feature to run
>>> Jetty with SPDY
>>> pax-http-jetty                  | 7.0.0            |          | Started
>>> | org.ops4j.pax.web-7.0.0           |
>>> pax-http                        | 7.0.0            |          | Started
>>> | org.ops4j.pax.web-7.0.0           | Implementation of the OSGI HTTP
>>> Service
>>> pax-http-whiteboard             | 7.0.0            |          | Started
>>> | org.ops4j.pax.web-7.0.0           | Provide HTTP Whiteboard pattern
>>> support
>>> pax-war                         | 7.0.0            |          | Started
>>> | org.ops4j.pax.web-7.0.0           | Provide support of a full
>>> WebContainer
>>> pax-http-tomcat                 | 7.0.0            |          |
>> Uninstalled
>>> | org.ops4j.pax.web-7.0.0           | Provide Tomcat support
>>> pax-war-tomcat                  | 7.0.0            |          |
>> Uninstalled
>>> | org.ops4j.pax.web-7.0.0           |
>>> pax-jsf-support                 | 7.0.0            |          |
>> Uninstalled
>>> | org.ops4j.pax.web-7.0.0           |
>>> pax-jsf-resources-support       | 7.0.0            |          |
>> Uninstalled
>>> | org.ops4j.pax.web-7.0.0           | Provide sharing of resources
>>> according
>>> to Servlet
>>> undertow                        | 1.4.23.Final     |          |
>> Uninstalled
>>> | org.ops4j.pax.web-7.0.0           |
>>> pax-http-undertow               | 7.0.0            |          |
>> Uninstalled
>>> | org.ops4j.pax.web-7.0.0           |
>>>
>>>
>>> is there any way to skip installing pax-web features in karaf
>>> -distribution.
>>>
>>> Thanks
>>> Sai
>>>
>>>
>>>
>>>
>>>
>>> --
>>> Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html
>>>
>>
>>
>> --
>> --
>> Christian Schneider
>> http://www.liquid-reality.de
>>
>> Computer Scientist
>> http://www.adobe.com
>>
> 

Mime
View raw message