karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: [HEADS UP] Releases schedule
Date Mon, 21 Jan 2019 07:40:57 GMT
Hi,

my intention was not to align all in a row but also to update to recent
Hibernate 5.2.x version (providing fixes).

I will prepare to PR at Hibernate to align anyway.

Regards
JB

On 21/01/2019 08:12, Grzegorz Grzybek wrote:
> Hello
> 
> After updating to hibernate 5.2.17.Final the state of _duplicates_ didn't
> change much.
> 
>  - hibernate 5.2.17.Final still uses mvn:com.fasterxml/classmate/1.3.0
> while hibernate-validator/6.0.13.Final uses
> mvn:com.fasterxml/classmate/1.3.4
>  - hibernate 5.2.17.Final "brings" mvn:net.bytebuddy/byte-buddy/1.6.14
> while Karaf uses mvn:net.bytebuddy/byte-buddy/1.6.6
>  - hibernate 5.2.17.Final upgraded to
> mvn:org.jboss.logging/jboss-logging/3.3.1.Final (from 3.3.0.Final), but
> that's still not mvn:org.jboss.logging/jboss-logging/3.3.2.Final provided
> by pax-web, pax-cdi and hibernate-validator
> 
> that's very easy to "align" externally (in any custom distro) using this
> etc/org.apache.karaf.features.xml:
> 
> <featuresProcessing xmlns="
> http://karaf.apache.org/xmlns/features-processing/v1.0.0"
>         xmlns:f="http://karaf.apache.org/xmlns/features/v1.5.0">
> 
>     <!-- A list of bundle URI replacements that allows changing external
> feature definitions -->
>     <bundleReplacements>
>         <bundle originalUri="mvn:com.fasterxml/classmate/[1.3,2)"
>                 replacement="mvn:com.fasterxml/classmate/1.3.4"
> mode="maven" />
>         <bundle originalUri="mvn:net.bytebuddy/byte-buddy/[1.6,2)"
>                 replacement="mvn:net.bytebuddy/byte-buddy/1.6.14"
> mode="maven" />
>         <bundle originalUri="mvn:org.jboss.logging/jboss-logging/[3.3,4)"
> 
> replacement="mvn:org.jboss.logging/jboss-logging/3.3.2.Final" mode="maven"
> />
>     </bundleReplacements>
> 
> </featuresProcessing>
> 
> regards
> Grzegorz Grzybek
> 
> niedz., 20 sty 2019 o 07:48 Jean-Baptiste Onofré <jb@nanthrax.net>
> napisał(a):
> 
>> Just to be clear:
>>
>> - Karaf 4.2.3 will upgrade to Hibernate 5.2.18.Final
>> - Karaf 4.3.x will upgrade to Hibernate 5.4.x.Final
>>
>> Regards
>> JB
>>
>> On 20/01/2019 07:36, Jean-Baptiste Onofré wrote:
>>> Hi Grzegorz,
>>>
>>> That's not for Karaf 4.2.x but Karaf 4.3.x.
>>>
>>> Regards
>>> JB
>>>
>>> On 20/01/2019 07:23, Grzegorz Grzybek wrote:
>>>> Hello
>>>>
>>>> Some time ago, I prepared this table
>>>> <
>> https://docs.google.com/spreadsheets/d/1TB_q5r9i8DOIHmBQa1_RjsrcjWCwCwsLPj3Pc6FoTJ8/edit#gid=1455909167
>>>
>>>> with JavaEE spec mapping (still work in progress wrt implementations).
>>>> Hibernate 5.3 == JPA 2.2 == JavaEE 8 thus → Servlets 4.0.
>>>>
>>>> That's not reason to *not* use Hibernate 5.3 - that's only an
>> opportunity
>>>> for me to put more efforts into
>> https://ops4j1.jira.com/browse/PAXWEB-1185
>>>> (Undertow 2) and https://ops4j1.jira.com/browse/PAXWEB-1187 (Tomcat 9).
>>>>
>>>> I even prepared
>>>> https://github.com/ops4j/org.ops4j.pax.web/commits/pax-web-7.3.x branch
>>>> (locally I work on master-servlet-4) and this looks promising - the only
>>>> thing left is to wait for Jetty 10...
>>>>
>>>> I guess my work related to servlets-4.0 should be ready for Karaf 4.3.0.
>>>>
>>>> regards
>>>> Grzegorz Grzybek
>>>>
>>>> niedz., 20 sty 2019 o 06:45 Jean-Baptiste Onofré <jb@nanthrax.net>
>>>> napisał(a):
>>>>
>>>>> I created Jira to provide new Hibernate versions and test it in Karaf.
>>>>>
>>>>> Regards
>>>>> JB
>>>>>
>>>>> On 19/01/2019 22:24, Robert Varga wrote:
>>>>>> On 18/01/2019 15:45, Grzegorz Grzybek wrote:
>>>>>>> Also check
>>>>> http://people.apache.org/~ggrzybek/bundle-report-full-karaf.xml
>>>>>>> report - it's perfectly aligned, not including hibernate features
>>>>> (which we
>>>>>>> use directly from upstream hibernate projects) - but nothing
that
>> can't
>>>>> be
>>>>>>> tweaked using etc/org.apache.karaf.features.xml.
>>>>>>
>>>>>> Without knowing anything about this: would it be possible to refresh
>> the
>>>>>> hibernate version? 5.2.9 seems to be rather ancient, with 5.2.18
out
>>>>>> there... Plus there is 5.3.x, which seems to trim down the feature
>>>>>> content, too.
>>>>>>
>>>>>> Regards,
>>>>>> Robert
>>>>>>
>>>>>
>>>>> --
>>>>> Jean-Baptiste Onofré
>>>>> jbonofre@apache.org
>>>>> http://blog.nanthrax.net
>>>>> Talend - http://www.talend.com
>>>>>
>>>>
>>>
>>
>> --
>> Jean-Baptiste Onofré
>> jbonofre@apache.org
>> http://blog.nanthrax.net
>> Talend - http://www.talend.com
>>
> 

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message