karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "munishgupta.asr" <munishgupta....@gmail.com>
Subject Re: How to Install Spring 4.3.21 on Karaf 4.2.2
Date Wed, 09 Jan 2019 12:20:18 GMT
Thanks for the answer JB.

I did as you suggested and used spring-legacy library and able to install
spring-dm and spring-dm.web. it is showing as started successfully. 

spring-dm        | 1.2.1            | x        | Started     |
spring-legacy-4.2.2               | Spring DM support
spring-dm-web    | 1.2.1            | x        | Started     |
spring-legacy-4.2.2               | Spring DM Web support
spring           | 3.2.18.RELEASE_1 |          | Started     |
spring-legacy-4.2.2               | Spring 3.2.x support
spring-web       | 3.2.18.RELEASE_1 |          | Started     |
spring-legacy-4.2.2               | Spring 3.2.x Web support

My intention of downgrading spring on KARAF 4.2.2 was to use
OsgiBundleXmlWebApplicationContext class (spring-dm) which is supported upto
KARAF 4 only. but while installing my web module, i again got this
ClassNotFoundException exception for OsgiBundleXmlWebApplicationContext
class. 

14:39:48,344 | INFO  | onfig-2-thread-2 | ContextLoader                    |
183 - org.apache.servicemix.bundles.spring-web - 3.2.18.RELEASE_1 | Root
WebApplicationContext: initialization started
14:39:48,345 | ERROR | onfig-2-thread-2 | ContextLoader                    |
183 - org.apache.servicemix.bundles.spring-web - 3.2.18.RELEASE_1 | Context
initialization failed
org.springframework.context.ApplicationContextException: Failed to load
custom context class [
     
org.springframework.osgi.web.context.support.OsgiBundleXmlWebApplicationContext
    ]; nested exception is java.lang.ClassNotFoundException: 
     
org.springframework.osgi.web.context.support.OsgiBundleXmlWebApplicationContext
     not found by docsconsole [321]
                at
org.springframework.web.context.ContextLoader.determineContextClass(ContextLoader.java:476)
~[183:org.apache.servicemix.bundles.spring-web:3.2.18.RELEASE_1]
                at
org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:355)
~[183:org.apache.servicemix.bundles.spring-web:3.2.18.RELEASE_1]

is not it supposed to work now?

Thanks



--
Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html

Mime
View raw message