karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ravi <ravisekhar...@motivitylabs.com>
Subject Proguard is not working in karaf 4.2.6
Date Thu, 20 Jun 2019 13:08:18 GMT
Hi Team
After we are upgraded our application from karaf 4.2.2 to 4.2.6 when
proguarding the compilation is failing below warning followed by exception.

[proguard] Warning: class
[META-INF/versions/9/javax/xml/bind/ModuleUtil.class] unexpectedly contains
class [javax.xml.bind.ModuleUtil]

[proguard] Warning: there were 1 classes in incorrectly named files.
[proguard] You should make sure all file names correspond to their class
names.
[proguard] The directory hierarchies must correspond to the package
hierarchies.
[proguard]
(proguard.sourceforge.net/manual/troubleshooting.html#unexpectedclass)
[proguard] If you don't mind the mentioned classes not being written out,
[proguard] you could try your luck using the '-ignorewarnings' option.
[proguard] java.io.IOException: Please correct the above warnings first.
[proguard] at proguard.InputReader.execute(InputReader.java:149)
[proguard] at proguard.ProGuard.readInput(ProGuard.java:255)
[proguard] at proguard.ProGuard.execute(ProGuard.java:96)
[proguard] at proguard.ProGuard.main(ProGuard.java:572)
[proguard] Reading library jar [C:\Program
Files\Java\jdk1.8.0_192\jre\lib\jsse.jar]
[proguard] Reading library jar [C:\Program
Files\Java\jdk1.8.0_192\jre\lib\jce.jar]

Any suggestions or help please.

Thanks,
Ravi



--
Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html

Mime
View raw message