karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Issue in bin/inc on 4.3.0-SNAPSHOT and 4.2.7-SNAPSHOT
Date Wed, 11 Sep 2019 16:50:17 GMT
Yeah, it's what I did (I forgot to do it before ;)).

Thanks for the tip !

Regards
JB

On 10/09/2019 21:27, Steinar Bang wrote:
>>>>>> Jean-Baptiste Onofré <jb@nanthrax.net>:
> 
>> Quick update about the bin/inc issue: it seems to be an environment
>> issue on one of my machine (I'm suspecting the CRLF git config).
>> I tested the SNAPSHOT deployed by Jenkins and it's working fine.
> 
> JB, FWIW, I run with an LF only setup, and this is how I do it:
>  1. I add an .editorconfig like this to all projects (works with
>     IntelliJ, eclipse and emacs, and probably more):
>      https://github.com/steinarb/authservice/blob/master/.editorconfig#L1
>  2. After cloning a repo on windows, before starting work, I do the
>     following: 
>      git config core.eol lf
>      git config core.autocrlf input
>      git rm -rf --cached .
>      git reset --hard HEAD
>    (it's a an annoyance (but a minor one) to remember to do this after a
>    fresh clone.  However after being bitten by strange behaviour and
>    unexpected results, I stay away from global git settings, and checked
>    in .gitconfig files)
> 

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message