karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob Paulin <...@bobpaulin.com>
Subject Re: Wrap protocol support for Java 11 jars
Date Sat, 09 Jan 2021 13:20:03 GMT
Thanks JB you rock!

-Bob
________________________________
From: Jean-Baptiste Onofre <jb@nanthrax.net>
Sent: Saturday, January 9, 2021 12:16:54 AM
To: dev@karaf.apache.org <dev@karaf.apache.org>
Subject: Re: Wrap protocol support for Java 11 jars

Hi Bob,

I will update bnd version in pax-url (I did it smoothly on Karaf) and cut the release to update
in Karaf.

It should not be a problem, I will keep you posted.

Regards
JB

> Le 9 janv. 2021 à 04:19, Bob Paulin <bob@bobpaulin.com> a écrit :
>
> Hi,
>
> I recently submitted an issue relate to a camel-karaf feature that uses the karaf wrap
command [1].  Karaf delegates this work to the pax-url-wrap library which uses a older version
of bndtools (2.3.0).  Trying to think of a way forward since the pax ecosystem as a whole
is mostly on bndtools 2.3.0.  Does it make sense to wait for pax to upgrade bndtools or might
it be possible to move the wrap code into Karaf?  Not sure if anyone else is looking at this
and has other ideas.  This is going to become more of a problem as more jars are complied
on more recent versions of Java.  Already starting to see this pop up in other places [2]
[3].  I think it would be good start discussing a path forward.  Thanks!
>
> - Bob
>
> [1] https://issues.apache.org/jira/browse/KARAF-6988
>
> [2] https://issues.apache.org/jira/browse/CAMEL-15662
>
> [3] https://stackoverflow.com/questions/57808832/apache-karaf-startup-arrayindexoutofboundsexception-19
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message