karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Created] (KARAF-2071) Minimal distribution doesn't start
Date Mon, 17 Dec 2012 16:51:31 GMT
Jean-Baptiste Onofré created KARAF-2071:
-------------------------------------------

             Summary: Minimal distribution doesn't start
                 Key: KARAF-2071
                 URL: https://issues.apache.org/jira/browse/KARAF-2071
             Project: Karaf
          Issue Type: Bug
          Components: karaf-core
    Affects Versions: 2.3.1
            Reporter: Jean-Baptiste Onofré
            Assignee: Jean-Baptiste Onofré
             Fix For: 2.3.1


When trying to start Karaf minimal distribution:

ERROR: Bundle org.apache.karaf.shell.console [14] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.console/2.3.1-SNAPSHOT
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.console
[14]: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0))))
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.console
[14]: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))
        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
        at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
        at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
        at java.lang.Thread.run(Thread.java:662)
ERROR: Bundle org.apache.karaf.shell.dev [15] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.dev/2.3.1-SNAPSHOT
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.dev
[15]: Unable to resolve 15.0: missing requirement [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))])
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.dev
[15]: Unable to resolve 15.0: missing requirement [15.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))]
        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
        at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
        at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
        at java.lang.Thread.run(Thread.java:662)
ERROR: Bundle org.apache.karaf.shell.commands [16] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.commands/2.3.1-SNAPSHOT
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.commands
[16]: Unable to resolve 16.0: missing requirement [16.0] osgi.wiring.package; (&(osgi.wiring.package=jline)(version>=2.9.0)(!(version>=3.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))])
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.commands
[16]: Unable to resolve 16.0: missing requirement [16.0] osgi.wiring.package; (&(osgi.wiring.package=jline)(version>=2.9.0)(!(version>=3.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))]
        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
        at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
        at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
        at java.lang.Thread.run(Thread.java:662)
ERROR: Bundle org.apache.karaf.features.command [18] Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.command/2.3.1-SNAPSHOT
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.command
[18]: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))])
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.command
[18]: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))]
        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
        at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
        at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
        at java.lang.Thread.run(Thread.java:662)
ERROR: Bundle org.apache.karaf.shell.log [19] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.log/2.3.1-SNAPSHOT
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.log
[19]: Unable to resolve 19.0: missing requirement [19.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))])
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.log
[19]: Unable to resolve 19.0: missing requirement [19.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))]
        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
        at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
        at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
        at java.lang.Thread.run(Thread.java:662)
ERROR: Bundle org.apache.karaf.features.management [23] Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.management/2.3.1-SNAPSHOT
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.management
[23]: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))])
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.management
[23]: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))]
        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
        at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
        at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
        at java.lang.Thread.run(Thread.java:662)
ERROR: Bundle org.apache.karaf.shell.packages [26] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.packages/2.3.1-SNAPSHOT
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages
[26]: Unable to resolve 26.0: missing requirement [26.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))])
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages
[26]: Unable to resolve 26.0: missing requirement [26.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))]
        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
        at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
        at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
        at java.lang.Thread.run(Thread.java:662)
ERROR: Bundle org.apache.karaf.shell.osgi [27] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.osgi/2.3.1-SNAPSHOT
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.osgi
[27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=jline)(version>=2.9.0)(!(version>=3.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))])
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.osgi
[27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=jline)(version>=2.9.0)(!(version>=3.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))]
        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
        at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
        at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
        at java.lang.Thread.run(Thread.java:662)
ERROR: Bundle org.apache.karaf.jaas.command [29] Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.command/2.3.1-SNAPSHOT
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.command
[29]: Unable to resolve 29.0: missing requirement [29.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))])
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.command
[29]: Unable to resolve 29.0: missing requirement [29.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.authz)(version>=2.3.0)(!(version>=3.0.0)))]
        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
        at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
        at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
        at java.lang.Thread.run(Thread.java:662)


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message